summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
commite5b6f1e7918fa647bd5e182c7ffaed43785b5ed5 (patch)
tree05955d3b163be1bb5f5042438af1a57e0fda24c7 /kde-plasma/plasma-nm
parentapp-misc/ca-certificates: fix double prefix (diff)
downloadgentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.gz
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.bz2
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.zip
kde-plasma: Add KDE Plasma 5.15.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.15.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 6a75f7f22916..bdc7338898e3 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.14.5.tar.xz 721144 BLAKE2B f9537e742be74b50ffeecee007ef91d93d108b566cf081cb4d25bc4d62c98847a74e7e69ec01b2f10e4e75eac4bc75cef90a3a47ad5ad199cec9f20c31bdaf20 SHA512 54667ff01db16bfadc1663dcf51668aed4eabcb70c3903538044bb478aeb4625d27777df13867cdf03048b6575a540de5c7baaef9e2dc2c41f458d2800daba96
DIST plasma-nm-5.15.0.tar.xz 771304 BLAKE2B 68fa17fa52244b2e2002c45a32b6e01e0335fde5eb2e41d70d64d7b9db72b257f0d6af1d0483e74bfe076c0beedb33c4f9a2ef8085dbaf3a588ead69196eee2d SHA512 4de7a60d6a0b6b67d5d26f0f21e969022b4b4785551a4894aa493c31b3ada8c3dd979b3131784c2ead0af9c5b09c5efee3e0b6ff18e75556927b2fbdb818b5a0
+DIST plasma-nm-5.15.1.tar.xz 771696 BLAKE2B 0eedef6d55332be5165bbe03ada9f932e422f43fee27319ddf6605456a42fa96390951769b92f6b8e34bebd8cc2e2d430e35a30a8ec43ddb70da447643a8aefa SHA512 f9237fabaffdce2767e2f877b4b226cb6eebcbf2ad3344cc6e2c764e0eb57077e1d0a602c00e64c31a4caf81dc9ddb952ec0b75d1490b4935fcbd07cf5e81a23
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.15.1.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.15.1.ebuild
new file mode 100644
index 000000000000..2d896c53ed9b
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.15.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}