summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 19:56:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 21:24:09 +0100
commitfb9e4f2d54dad43d39c2ae04a45e790d460bf6b1 (patch)
treecd2e14c7b513dcb87e546c3ed9b4feadc1bb121a /kde-plasma/plasma-nm
parentnet-dns/pdns-recursor: Stable on am64/x86, bug #671982 (diff)
downloadgentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.gz
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.bz2
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.zip
kde-plasma: Add KDE Plasma 5.14.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.14.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index f4978d0eb553..ccb0f9b0b3a4 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.13.5.tar.xz 705984 BLAKE2B 0a00bb3696ebc4ee5f26746cb1c1e9ef14e456abf448faf17d8ddb919f272354a88969ac54447ac626640d260c8bc1c4ffe3a578e3d2683c5efdf80d9b7d9a4b SHA512 13c0c5c27a5d01cf20093f314ff620658688fb10dfa052419b54f37e6de20fc947b120c7c9f3df5b3e8f3d92a1e701674c917456dbfb681c94e06a1da0456ead
DIST plasma-nm-5.14.3.tar.xz 718288 BLAKE2B 6fc68e0bf8661519889bead3b816cd51159dd1f48fb4243e4e8adb2097d9297d33d8246947ac92170d0290855f8b80f344d1f456e24c1f2007fa5333b3fc7bea SHA512 6337c35407074c649645df447b0502fce853115514e28fd216be0738bb35c86c3ec8313780ef6d7e4df3836c44851d644a07190c2333a1bb583e612056bc22a2
+DIST plasma-nm-5.14.4.tar.xz 720820 BLAKE2B 2d608da282990ecd3d0dd4ae50c9f930880a5bb07f2f095f38019ea59efff70925c938e71d282ce18ad4d7e5d30006cd9d54ca7f3bcda0ca9b929dc36579b83c SHA512 a0bf08c4d700b00a32209b76eed75d95dfdc2271308c16181d54a234f5b0b18636beff6172cba3c0398aa14eaab5c2ae14054cc3239a8388329e14e8ed044ec1
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.14.4.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.14.4.ebuild
new file mode 100644
index 000000000000..86195daf5637
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.14.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}