summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-23 02:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-23 08:26:18 +0200
commit98d8f7d6c61abac786b42ac8ed093d7258b6588e (patch)
tree3beb50875ff9e94d95348ca26ba60eb54d6d26a9 /kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild
parentkde-plasma/plasma-systemmonitor: 5.22.2 version bump (diff)
downloadgentoo-98d8f7d6c61abac786b42ac8ed093d7258b6588e.tar.gz
gentoo-98d8f7d6c61abac786b42ac8ed093d7258b6588e.tar.bz2
gentoo-98d8f7d6c61abac786b42ac8ed093d7258b6588e.zip
kde-plasma/plasma-thunderbolt: 5.22.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild')
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild
new file mode 100644
index 000000000000..952807b2c0bd
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.22.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# tests require DBus
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ sys-apps/bolt
+"