summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 14:35:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 16:32:29 +0200
commit3a88c6f1b382ab5ebfe61539039a694c0e123991 (patch)
tree08f3cf35bc863ba6278e2950b9c5e72e83efe7be /kde-plasma/xdg-desktop-portal-kde
parentacct-group/kvm: make virtualization the primary maintainer (diff)
downloadgentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.gz
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.bz2
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.zip
kde-plasma: Add KDE Plasma 5.16.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 092f50e7d74d..bac35254d4e4 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.15.5.tar.xz 60292 BLAKE2B 5e0f07ec5e57d978c444fc65e1aa70b04dea458d34d9c091da5699501995499fb877e90ae0272634fc7dd62fa192a99d7f800bf7627612e2eafb6763e3f732ca SHA512 f575c9a5273cef3ab34a7eb4be520cdec3344fd6729f79d4475f200a177fba40b265815136c4af18ce6e48c9736bb835af4d972c5563171ead2e4390e938fcbf
DIST xdg-desktop-portal-kde-5.16.3.tar.xz 61560 BLAKE2B d6c3c58f9f75295693fec28634bfc317b3a9d100208090a536b1be44e4e7498dff97ba34066dada9780514036112576abccb2d07cdffd83f3167a7b74dbf5001 SHA512 98ab00255ebd535525f909008304d10f6c94edb9be6a32488bc943279d0169bb70c48c05863795045568d0b404d1b088f298b80d869fbacb502ff812fd772732
+DIST xdg-desktop-portal-kde-5.16.4.tar.xz 61804 BLAKE2B b32366b815c076b24350c65fd86ad7cbbf0063c9167b5694b897257b4dc1aa78fd9e4bd2be34027d9f9b8f3514503334802475fb1e6410e8c60c0240b055ce76 SHA512 401d25bff09c844f9f214234bc8a2ce0975f03adc959079744a4550f56e4b2d38db2105e1392559c681ff04eb9e586d1916cbf7fc59ba6758e610eba927c8009
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.4.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.4.ebuild
new file mode 100644
index 000000000000..0f81e42f3e0b
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport 'cups')
+ $(add_qt_dep qtwidgets)
+ screencast? (
+ dev-libs/glib:2
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwayland)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ screencast? ( sys-apps/xdg-desktop-portal[screencast] )
+ !screencast? ( sys-apps/xdg-desktop-portal )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package screencast GLIB2)
+ $(cmake-utils_use_find_package screencast PipeWire)
+ $(cmake-utils_use_find_package screencast GBM)
+ $(cmake-utils_use_find_package screencast Epoxy)
+ )
+ kde5_src_configure
+}