summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 19:27:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 23:08:18 +0100
commit6adb5443037382add02196d68c5612c9aa30693a (patch)
tree6588679e29e2e00df6cae5ab1e06329a49f46f2b /kde-plasma/xembed-sni-proxy
parentmedia-libs/qtav: Fix build w/ Qt 5.14 (diff)
downloadgentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.gz
gentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.bz2
gentoo-6adb5443037382add02196d68c5612c9aa30693a.zip
kde-plasma: Add KDE Plasma 5.17.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy')
-rw-r--r--kde-plasma/xembed-sni-proxy/Manifest1
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.17.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/Manifest b/kde-plasma/xembed-sni-proxy/Manifest
index 56ea59d0be0d..2dcf210d7d6e 100644
--- a/kde-plasma/xembed-sni-proxy/Manifest
+++ b/kde-plasma/xembed-sni-proxy/Manifest
@@ -1 +1,2 @@
DIST plasma-workspace-5.17.4.tar.xz 4962200 BLAKE2B 2050dbf77dbdf144017e0ddf4b827b9dbe27b8f475eedaed969a442e036f162cabad5d6b47fd650491ed5989cade48ebafbd5f599dbc790c14515ce01ebfd626 SHA512 3f5aa07ccd19604bc399bb1d30dd16ac82e1405613c1f4a939e3c2cba3b4a478213095617052440dda222f1712608533e5806939117752d31b0616a6009cf45b
+DIST plasma-workspace-5.17.5.tar.xz 4962336 BLAKE2B d7c91130d303b612cae09627947547919d44ce91f31340bea4b8987ecc688728e0d937364c76710e0989554282688765bba58308cbb36c889e6729a6fbb7043a SHA512 b8a3f3a1a79d7254deecfb5228749abf15bc6f58ab17eb6d19e9010c74930491439aefa6589980dc0ae53858e4bef6be7edb66a15d3f227c5dfff458c1ca5d1a
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.17.5.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.17.5.ebuild
new file mode 100644
index 000000000000..dc13af98ef7e
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.17.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="plasma-workspace"
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit cmake kde.org
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/extra-cmake-modules-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.90-standalone.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}