summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-07 20:29:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:38 +0200
commitb3b5564327f160ed033b7c2d7781f0bb99f9dc85 (patch)
treebf8082f2f50b947e1305e878144414a8939194e3 /kde-plasma/xembed-sni-proxy
parentnet-misc/vde: No more ltprune (diff)
downloadgentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.gz
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.bz2
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.zip
kde-plasma: Add KDE Plasma 5.15.5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy')
-rw-r--r--kde-plasma/xembed-sni-proxy/Manifest1
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/Manifest b/kde-plasma/xembed-sni-proxy/Manifest
index 4577623dacbb..3f44ff0db539 100644
--- a/kde-plasma/xembed-sni-proxy/Manifest
+++ b/kde-plasma/xembed-sni-proxy/Manifest
@@ -1,2 +1,3 @@
DIST plasma-workspace-5.14.5.tar.xz 4578556 BLAKE2B 3c37bd9f880225f0e8b2496b90e5afc5ad591e8e356bd68ae135c3e9ccfe646adcb2418e2e80185f396c3b412f0df603ba0902e5a6d54a6d9a5abdff500a71f7 SHA512 247abdfe4ed4c7b6bb847c5352b3df11d110d59f8cc62b51dfd9de76c62549a0191efdd1e1f5a6ab82a87eccdc9fd28481a85c1252d05595e0f1a72174b3f8c6
DIST plasma-workspace-5.15.4.tar.xz 4718764 BLAKE2B 97bc658aee21fb4e3f8a095462f55a0a1d7fe4c1c201e6bc5ce7d8ba51dd971f747bd447c091fb51ad2b09a4f13e78b2f15e1e78e52b6827463bf1d45defd44b SHA512 720f061ab1017e6558c4079e18f6cf88cf5bd04e2484e8f68e784708d9507fb96ae705360c143525cbccdc83843e489e30ebd4f0703ed82f339971fc1c4547ea
+DIST plasma-workspace-5.15.5.tar.xz 4713728 BLAKE2B 7ce14912bf0dc2556484b7b719b00e7296fb67d78faabb9e3c00fbfb56a41db04e27b5f94636142f07e88e24d51ff308025a50d719a940e1287943a35db93e79 SHA512 5d5429114a733d4328f7db6c8e3c7dfe5e04862f8083fcad40b21390efb309c58fd1b13cf63aa57f2842c38936b9fe1c60ad61fc601cf4f592b86285c2270bed
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.5.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.5.ebuild
new file mode 100644
index 000000000000..54a97db0e7e7
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_AUTODEPS="false"
+KMNAME="plasma-workspace"
+inherit kde5
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.90-standalone.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}