summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-22 22:38:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 00:01:02 +0100
commitc3dc7b064538c4b283eda4b06d99b66e9dbe897e (patch)
treeb4a98f805ea9c487567045f6a3e468eed3047dd7 /kde-plasma
parentkde-plasma/plasma-workspace: drop 5.27.3 (diff)
downloadgentoo-c3dc7b064538c4b283eda4b06d99b66e9dbe897e.tar.gz
gentoo-c3dc7b064538c4b283eda4b06d99b66e9dbe897e.tar.bz2
gentoo-c3dc7b064538c4b283eda4b06d99b66e9dbe897e.zip
kde-plasma/plasma-desktop: kicker: Hide separators when sorted a..z
Upstream commit d492a691d44a2878eb3c189219dc04260294bb77 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=465865 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.27.3-kicker-hide-separators.patch77
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.27.3-r1.ebuild180
2 files changed, 257 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.27.3-kicker-hide-separators.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.27.3-kicker-hide-separators.patch
new file mode 100644
index 000000000000..30f95a901839
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.27.3-kicker-hide-separators.patch
@@ -0,0 +1,77 @@
+From d492a691d44a2878eb3c189219dc04260294bb77 Mon Sep 17 00:00:00 2001
+From: Joshua Goins <josh@redstrate.com>
+Date: Sat, 18 Mar 2023 10:39:49 -0400
+Subject: [PATCH] applets/kicker: Hide separators when sorted alphabetically
+
+Users are able to manually add separator items at custom positions in
+their menu structures. When they do so, the location of these
+separators are inherently custom, and only make sense when the menu
+structure is being displayed in its custom order. When using the option
+to display everything alphabetically, the separators' custom position
+no longer exists and any automatic placement becomes nonsensical.
+
+Currently, the separators get sorted to the beginning of the list,
+which looks quite weird. This commit instead hides the separators when
+sorting alphabetically. Only Kicker is affected by this change; the
+underlying model providing the items is unchanged.
+
+BUG: 465865
+FIXED-IN: 5.27.4
+(cherry picked from commit 90ad64ba638649b68cf2ffb7f68e227e86a8b8f1)
+---
+ applets/kicker/package/contents/ui/ItemListDelegate.qml | 4 +++-
+ applets/kicker/package/contents/ui/ItemListDialog.qml | 2 ++
+ applets/kicker/package/contents/ui/ItemListView.qml | 2 +-
+ 3 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/applets/kicker/package/contents/ui/ItemListDelegate.qml b/applets/kicker/package/contents/ui/ItemListDelegate.qml
+index 0eefe24e9e..ea7a0455c9 100644
+--- a/applets/kicker/package/contents/ui/ItemListDelegate.qml
++++ b/applets/kicker/package/contents/ui/ItemListDelegate.qml
+@@ -25,6 +25,7 @@ Item {
+
+ readonly property real fullTextWidth: Math.ceil(icon.width + label.implicitWidth + arrow.width + row.anchors.leftMargin + row.anchors.rightMargin + row.actualSpacing)
+ property bool isSeparator: (model.isSeparator === true)
++ property bool sorted: (model.sorted === true)
+ property bool hasChildren: (model.hasChildren === true)
+ property bool hasActionList: ((model.favoriteId !== null)
+ || (("hasActionList" in model) && (model.hasActionList === true)))
+@@ -251,7 +252,8 @@ Item {
+ anchors.rightMargin: highlightItemSvg.margins.right
+ anchors.verticalCenter: parent.verticalCenter
+
+- active: item.isSeparator
++ // Separator positions don't make sense when sorting everything alphabetically
++ active: item.isSeparator && !item.sorted
+
+ asynchronous: false
+ sourceComponent: separatorComponent
+diff --git a/applets/kicker/package/contents/ui/ItemListDialog.qml b/applets/kicker/package/contents/ui/ItemListDialog.qml
+index ffdb2e97c8..d97650cbbe 100644
+--- a/applets/kicker/package/contents/ui/ItemListDialog.qml
++++ b/applets/kicker/package/contents/ui/ItemListDialog.qml
+@@ -70,6 +70,8 @@ Kicker.SubMenu {
+ Kicker.FunnelModel {
+ id: funnelModel
+
++ property bool sorted: sourceModel.hasOwnProperty("sorted") ? sourceModel.sorted : false
++
+ Component.onCompleted: {
+ kicker.reset.connect(funnelModel.reset);
+ }
+diff --git a/applets/kicker/package/contents/ui/ItemListView.qml b/applets/kicker/package/contents/ui/ItemListView.qml
+index 29ff51da05..d931b9fcff 100644
+--- a/applets/kicker/package/contents/ui/ItemListView.qml
++++ b/applets/kicker/package/contents/ui/ItemListView.qml
+@@ -30,7 +30,7 @@ FocusScope {
+ property int itemHeight: Math.ceil((Math.max(theme.mSize(theme.defaultFont).height, PlasmaCore.Units.iconSizes.small)
+ + Math.max(highlightItemSvg.margins.top + highlightItemSvg.margins.bottom,
+ listItemSvg.margins.top + listItemSvg.margins.bottom)) / 2) * 2
+- property int separatorHeight: lineSvg.horLineHeight + (2 * PlasmaCore.Units.smallSpacing)
++ property int separatorHeight: model.sorted === true ? 0 : lineSvg.horLineHeight + (2 * PlasmaCore.Units.smallSpacing)
+
+ property alias currentIndex: listView.currentIndex
+ property alias currentItem: listView.currentItem
+--
+GitLab
+
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.27.3-r1.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.27.3-r1.ebuild
new file mode 100644
index 000000000000..4a4ff2f230a9
--- /dev/null
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.27.3-r1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+VIRTUALX_REQUIRED="test"
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="KDE Plasma desktop"
+XORGHDRS="${PN}-override-include-dirs-2"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${XORGHDRS}.tar.xz"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="ibus +kaccounts scim screencast +semantic-desktop"
+
+# kde-frameworks/kwindowsystem[X]: Uses KX11Extras
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/attica-${KFMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ >=kde-plasma/kwin-${PVCUT}:5
+ >=kde-plasma/libksysguard-${PVCUT}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5[screencast?]
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ ibus? (
+ app-i18n/ibus
+ dev-libs/glib:2
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+ kaccounts? (
+ kde-apps/kaccounts-integration:5
+ net-libs/accounts-qt
+ )
+ scim? ( app-i18n/scim )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/wayland-protocols-1.25
+ dev-libs/boost
+ x11-base/xorg-proto
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/kdeplasma-addons-5.25.50
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/oxygen-${PVCUT}:5
+ media-fonts/noto-emoji
+ sys-apps/util-linux
+ x11-apps/setxkbmap
+ x11-misc/xdg-user-dirs
+ kaccounts? ( net-libs/signon-oauth2 )
+ screencast? ( >=kde-plasma/kpipewire-${PVCUT}:5 )
+"
+BDEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${WORKDIR}/${XORGHDRS}/${PN}-5.25.80-override-include-dirs.patch" # downstream patch
+ "${FILESDIR}/${P}-kicker-hide-separators.patch" # KDE-bug 465865
+)
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use ibus; then
+ sed -e "s/Qt5X11Extras_FOUND AND XCB_XCB_FOUND AND XCB_KEYSYMS_FOUND/false/" \
+ -i applets/kimpanel/backend/ibus/CMakeLists.txt || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if ! use scim; then
+ sed -e "s/^pkg_check_modules.*SCIM/#&/" -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON # not packaged
+ -DEVDEV_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGLIBINPUT_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGSERVER_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DSYNAPTICS_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ $(cmake_use_find_package ibus GLIB2)
+ $(cmake_use_find_package kaccounts AccountsQt5)
+ $(cmake_use_find_package kaccounts KAccounts)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # parallel tests fail, foldermodeltest,positionertest hang, bug #646890
+ # test_kio_fonts needs D-Bus, bug #634166
+ # lookandfeel-kcmTest is unreliable for a long time, bug #607918
+ local myctestargs=(
+ -j1
+ -E "(foldermodeltest|positionertest|test_kio_fonts|lookandfeel-kcmTest)"
+ )
+
+ ecm_src_test
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "screen reader support" app-accessibility/orca
+ fi
+ ecm_pkg_postinst
+}