summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-28 21:07:30 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-28 21:07:30 +0200
commit435fe696449f4e83dc845a0e8b24a94affecb3d2 (patch)
tree316868cda4a479d412074d78b1bdb213ef727ed5 /lxqt-base/lxqt-common
parentlxqt-base/lxqt-session: Version bump to 0.11.0 (diff)
downloadgentoo-435fe696449f4e83dc845a0e8b24a94affecb3d2.tar.gz
gentoo-435fe696449f4e83dc845a0e8b24a94affecb3d2.tar.bz2
gentoo-435fe696449f4e83dc845a0e8b24a94affecb3d2.zip
lxqt-base/lxqt-common: Version bump to 0.11.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'lxqt-base/lxqt-common')
-rw-r--r--lxqt-base/lxqt-common/Manifest1
-rw-r--r--lxqt-base/lxqt-common/lxqt-common-0.11.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-common/Manifest b/lxqt-base/lxqt-common/Manifest
index 2dec945f9308..df76ffdecb7a 100644
--- a/lxqt-base/lxqt-common/Manifest
+++ b/lxqt-base/lxqt-common/Manifest
@@ -1 +1,2 @@
DIST lxqt-common-0.10.0.tar.xz 3986324 SHA256 7b12f2fe7a42f5ea0c9f596eeb87ca3c97cc0b706121ceede64480e8480ec9d1 SHA512 bdfc93844724bc906c000b310063a815da15b0e34774da35f0536009fe63f45d1bf7f7b767b20fead013c10bead271a964a2826cf700f14a2a40717614f3b57e WHIRLPOOL 3c09d35845e41d74630ca05c5aff17dad909758044764a208c0a73c9e5cca901cbd7ed89ef3806c32e34f0c95c87df06a03457db1b47403f4a08521e0f6f43fb
+DIST lxqt-common-0.11.0.tar.xz 3216520 SHA256 3a34a2105a49545d2695cccaf6310d261a7e760455e583efa2d80b3ab54d6053 SHA512 5eeaa6ead263a93b58ab9ec536c287fe383b5abade722dd3c7232840bc12c56e2208904bfbbc5ee9092c340d14d939a2ac0dcd37cf2175a0f601bbe050f00a2c WHIRLPOOL 7c889291741a729ea642eeb14cdf0aa7fb4bb78aa2a0d6ede64ff8bae9ca6091649ab39642d3477fbc498e35ec021b4bf255db536e5c88a8da21681b039639e3
diff --git a/lxqt-base/lxqt-common/lxqt-common-0.11.0.ebuild b/lxqt-base/lxqt-common/lxqt-common-0.11.0.ebuild
new file mode 100644
index 000000000000..ff7f405a2b59
--- /dev/null
+++ b/lxqt-base/lxqt-common/lxqt-common-0.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt common resources"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND=">=lxqt-base/liblxqt-0.11.0"
+RDEPEND="${DEPEND}"
+PDEPEND=">=lxqt-base/lxqt-session-0.11.0"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodir "/etc/X11/Sessions"
+ dosym "/usr/bin/startlxqt" "/etc/X11/Sessions/lxqt"
+}