summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-27 00:51:01 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-27 00:51:01 +0200
commitd541a6ed472f6f374372404629d0925ab4574c23 (patch)
treea5c90704e315044f25f4f2205f6ad3c4a1e2dbb6 /lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild
parentlxqt-base/lxqt-globalkeys: Version bump to 0.11.0 (diff)
downloadgentoo-d541a6ed472f6f374372404629d0925ab4574c23.tar.gz
gentoo-d541a6ed472f6f374372404629d0925ab4574c23.tar.bz2
gentoo-d541a6ed472f6f374372404629d0925ab4574c23.zip
lxqt-base/lxqt-config: Version bump to 0.11.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild')
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild
new file mode 100644
index 000000000000..a2b2c20b3de8
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.11.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ kde-plasma/libkscreen:5=
+ ~lxqt-base/liblxqt-${PV}
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes"
+DEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+RDEPEND="${CDEPEND}
+ x11-apps/setxkbmap"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}