summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 22:22:56 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-10 14:55:33 +0200
commitf1ffb6c7043296d833409c02b2e81bd1e99f36f7 (patch)
treec3b88154253ddb8e276d43f8220954b799418530 /lxqt-base/lxqt-notificationd
parentlxqt-base/lxqt-globalkeys: add version 1.2.0 (diff)
downloadgentoo-f1ffb6c7043296d833409c02b2e81bd1e99f36f7.tar.gz
gentoo-f1ffb6c7043296d833409c02b2e81bd1e99f36f7.tar.bz2
gentoo-f1ffb6c7043296d833409c02b2e81bd1e99f36f7.zip
lxqt-base/lxqt-notificationd: add version 1.2.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 12ee6fa1259b..6162ebf300e0 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,4 @@
DIST lxqt-notificationd-0.17.0.tar.xz 53712 BLAKE2B d15f00179eb24c43add51f246b46738d4da6f9ce89f041a65ce4acc252ebd0a832519c0e9e7ac2ee86d23806a2ac6a9a740b57fc5e88d73a09d1170e405386ef SHA512 042d69e01c3015d254ae3472867de0b41587af2285cd26445cd9d6d455de8ef713413431dea9997f2d2e19f70c2c8c73af39ce880d54ecb9fd6c50cd05a7dba4
DIST lxqt-notificationd-1.0.0.tar.xz 57160 BLAKE2B 518822c8fc4e5d8d68ae8181d64f80dc4dd0ffb7cc192f69432efaa7f35242c8e222b45cf51eaad473c8b55df09fd66475f7c1f9343d7d9b24c757304cef061a SHA512 e8953c06be5821d875027692589dd80bfc7bca8ff9d7e590dcab2ab80b17ed530983119b0cf9d254ba5b15bf863eb6283896e6ae38a999437e5ccd7d3a50adf9
DIST lxqt-notificationd-1.1.0.tar.xz 59596 BLAKE2B 5ae9e152d3f95fafa986e611efa2cc873971ba67719f27cc71dc08ca90f7dacea285fc552703b8ade1d86c4e9b7fb909e54ffd07a7d3de5f20989ac503580f89 SHA512 fd4ecdff4e32886959dd8806d247e7bfa5920a3b3c8f98066577758ab7d3884b15c9b791982e9b05a581b04ac09e6eb7d127172a930acf639e1378f997bd583f
+DIST lxqt-notificationd-1.2.0.tar.xz 60720 BLAKE2B 90d2676e4efd3a46bd6e11becf815c9746bf7ae9f8bb5de5ba48df5af433c91a285f048139cf87a3d1857c2c79ff904e75fdb3b085da80b51e196c07e17e488e SHA512 55ae52cf45942ee7992b099cbea1f81776ab7cc17401f903772458dee3e7ea1899bda13c5e6c5e117b2397dbbbe349c6e06dd389f51b03d4853b2f93c5cb000a
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.2.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.2.0.ebuild
new file mode 100644
index 000000000000..a3ec4967f1bb
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.12.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.10.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"