summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-05-21 20:49:47 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 21:47:43 +0200
commit1813c343ab9b0eea177b488fd5caeb52eeb6c34f (patch)
tree7ba808f75c2dbc1b5311dadbadabf03480bb9a12 /lxqt-base/lxqt-qtplugin
parentx11-misc/kapow: Drop 1.5.8 (diff)
downloadgentoo-1813c343ab9b0eea177b488fd5caeb52eeb6c34f.tar.gz
gentoo-1813c343ab9b0eea177b488fd5caeb52eeb6c34f.tar.bz2
gentoo-1813c343ab9b0eea177b488fd5caeb52eeb6c34f.zip
lxqt-base/lxqt-qtplugin: bump 'dev-libs/libqtxdg' dependency
Closes: https://bugs.gentoo.org/724436 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15904 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-qtplugin')
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..00aeff17f9a7
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt:=[qt5(+)]
+ >=dev-libs/libqtxdg-3.5.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"