summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 20:48:40 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:27 +0200
commitf3d9f475ddd73798ce10ef89a2154d09ae93c6d8 (patch)
tree84c6cf5dfe1ae5dd2ce84be3e3e4a157b576e55b /lxqt-base/lxqt-qtplugin
parentx11-libs/libfm-qt: add version 0.15.1 (diff)
downloadgentoo-f3d9f475ddd73798ce10ef89a2154d09ae93c6d8.tar.gz
gentoo-f3d9f475ddd73798ce10ef89a2154d09ae93c6d8.tar.bz2
gentoo-f3d9f475ddd73798ce10ef89a2154d09ae93c6d8.zip
lxqt-base/lxqt-qtplugin: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-qtplugin')
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest1
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
index d9acca89a571..074ae9fefd62 100644
--- a/lxqt-base/lxqt-qtplugin/Manifest
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -1 +1,2 @@
DIST lxqt-qtplugin-0.14.0.tar.xz 22336 BLAKE2B 8155722880cff279aa26676ed425a011b2259ba94bf92122c59643a0ac6dd89b2841bcbeeac26ac24ef1e351dcdbcabf339c4a2bcee2dac30f2f9298434f7294 SHA512 33188bc03ee48a9b6e3cc5823cdcb5c96dba0cda65da511fe603d952c5de24e292cb02208cf357b04718df90f98d53bf48eaf6793d70d043214e429f57ccf53c
+DIST lxqt-qtplugin-0.15.0.tar.xz 22776 BLAKE2B 642270939ddaf9884da611d800c6ccae518a2c259e2da37c3e0025e24a6a11bae1d21cc9d4141821dfcf2e6e4c9b383e800dc68ff9d5f9b39f2e27e121d158c7 SHA512 9a73b9d38e1c2e2e030b551f92d53afef69fedee8f0ff4c7147680c0037a3eacb98f5514e09f16762c03cdaded7e5f760a89d66461bab4d7e8877ebaba28160e
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild
new file mode 100644
index 000000000000..6e0fc33f885e
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt:=[qt5(+)]
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"