summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 20:29:02 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:06:39 +0300
commit458052dbf1ab86375e29a7b1e0647443ff99a316 (patch)
tree124d8fece85565cfe4efe4a1a38a36089966ce27 /lxqt-base
parentmedia-sound/pavucontrol-qt: add version 0.17.0 (diff)
downloadgentoo-458052dbf1ab86375e29a7b1e0647443ff99a316.tar.gz
gentoo-458052dbf1ab86375e29a7b1e0647443ff99a316.tar.bz2
gentoo-458052dbf1ab86375e29a7b1e0647443ff99a316.zip
lxqt-base/lxqt-meta: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/20414 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-meta/lxqt-meta-0.17.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-meta/lxqt-meta-0.17.0.ebuild b/lxqt-base/lxqt-meta/lxqt-meta-0.17.0.ebuild
new file mode 100644
index 000000000000..67747b9e788d
--- /dev/null
+++ b/lxqt-base/lxqt-meta/lxqt-meta-0.17.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="$(ver_cut 1-2)*"
+
+DESCRIPTION="Meta ebuild for LXQt, the Lightweight Desktop Environment"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="metapackage"
+SLOT="0"
+
+IUSE="+about admin archiver +display-manager +filemanager lximage
+minimal nls +policykit powermanagement processviewer screenshot +sddm
+ssh-askpass sudo terminal +trash"
+
+REQUIRED_USE="trash? ( filemanager )"
+
+# Note: we prefer kde-frameworks/oxygen-icons over other icon sets, as the initial
+# install expects oxygen icons, until the user specifies otherwise (bug 543380)
+RDEPEND="
+ kde-frameworks/oxygen-icons
+ >=lxde-base/lxmenu-data-0.1.5
+ =lxqt-base/lxqt-config-${MY_PV}
+ =lxqt-base/lxqt-globalkeys-${MY_PV}
+ =lxqt-base/lxqt-notificationd-${MY_PV}
+ =lxqt-base/lxqt-panel-${MY_PV}
+ =lxqt-base/lxqt-qtplugin-${MY_PV}
+ =lxqt-base/lxqt-runner-${MY_PV}
+ =lxqt-base/lxqt-session-${MY_PV}
+ virtual/ttf-fonts
+ x11-terms/xterm
+ =x11-themes/lxqt-themes-${MY_PV}
+ about? ( =lxqt-base/lxqt-about-${MY_PV} )
+ admin? ( =lxqt-base/lxqt-admin-${MY_PV} )
+ archiver? ( app-arch/lxqt-archiver )
+ display-manager? (
+ sddm? ( >=x11-misc/sddm-0.11.0 )
+ !sddm? ( x11-misc/lightdm )
+ )
+ filemanager? ( =x11-misc/pcmanfm-qt-${MY_PV} )
+ lximage? ( media-gfx/lximage-qt )
+ !minimal? (
+ x11-wm/openbox
+ x11-misc/obconf-qt
+ )
+ nls? ( dev-qt/qttranslations:5 )
+ policykit? ( =lxqt-base/lxqt-policykit-${MY_PV} )
+ powermanagement? ( =lxqt-base/lxqt-powermanagement-${MY_PV} )
+ processviewer? ( x11-misc/qps:0 )
+ screenshot? ( x11-misc/screengrab:0 )
+ sddm? ( >=x11-misc/sddm-0.11.0 )
+ ssh-askpass? ( =lxqt-base/lxqt-openssh-askpass-${MY_PV} )
+ sudo? ( =lxqt-base/lxqt-sudo-${MY_PV} )
+ terminal? ( x11-terms/qterminal:0 )
+ trash? ( gnome-base/gvfs )
+"