summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 22:03:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:43 +0100
commit8d71a37cb83c0d68b371c491566949cac88e024f (patch)
tree47990ee6fec6f97a1f866f89545cb0b7cc5486d4 /lxqt-base
parentlxqt-base/lxqt-admin: version bump to 0.14.1 (diff)
downloadgentoo-8d71a37cb83c0d68b371c491566949cac88e024f.tar.gz
gentoo-8d71a37cb83c0d68b371c491566949cac88e024f.tar.bz2
gentoo-8d71a37cb83c0d68b371c491566949cac88e024f.zip
lxqt-base/lxqt-config: version bump to 0.14.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-config/Manifest1
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild73
-rw-r--r--lxqt-base/lxqt-config/metadata.xml3
3 files changed, 76 insertions, 1 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
index cf057c2d3154..87fead0cfab1 100644
--- a/lxqt-base/lxqt-config/Manifest
+++ b/lxqt-base/lxqt-config/Manifest
@@ -1 +1,2 @@
DIST lxqt-config-0.13.0.tar.xz 201112 BLAKE2B 6a79c1f07e1cf055da09bb7dd8f7da2426891770b0e757ba3c4e5ef137f715ba3a579b2c05a4f1938c9d76b6dda0643119888be7dace2083a57a7dfe0df93aa5 SHA512 a5102794c4cf18a18e633cbc7d0b89653abf2612bc61e506ec169f4898903092f5201a09a2610642c641a17b59a992a6d6f59366ec61d54763e8b911d5220ca9
+DIST lxqt-config-0.14.1.tar.xz 293304 BLAKE2B f090d7878815edc4f3f0078301a099ffc8ff57865516a9097db75faa1627af33c60d76b75cef8a7da5e9e790869e6768f54c3b17c59b038578f22d645c3c22fd SHA512 747644f8e0623cb2e8eadda57c7307387423152a089d5b423b06650fbf235371764a26e82363cbee9db5c1145e3fdb754e6ecdcf0930dccec375dda424c8b13f
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild
new file mode 100644
index 000000000000..838fe79c5218
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
+SLOT="0"
+IUSE="+monitor +touchpad"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-libs/zlib:=
+ x11-apps/setxkbmap
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ monitor? ( kde-plasma/libkscreen:5= )
+ touchpad? (
+ virtual/libudev
+ x11-drivers/xf86-input-libinput
+ x11-libs/libXext
+ )
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MONITOR="$(usex monitor)"
+ -DWITH_TOUCHPAD="$(usex touchpad)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/lxqt-base/lxqt-config/metadata.xml b/lxqt-base/lxqt-config/metadata.xml
index d6f2207daed6..f6bf1a5dc530 100644
--- a/lxqt-base/lxqt-config/metadata.xml
+++ b/lxqt-base/lxqt-config/metadata.xml
@@ -9,6 +9,7 @@
<remote-id type="github">lxqt/lxqt-config</remote-id>
</upstream>
<use>
- <flag name="monitor" restrict="&gt;=lxqt-base/lxqt-config-0.13.0">Build monitor settings tool</flag>
+ <flag name="monitor">Build monitor settings tool</flag>
+ <flag name="touchpad">Build touchpad settings tool</flag>
</use>
</pkgmetadata>