summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2022-06-11 14:33:48 +0200
committerSam James <sam@gentoo.org>2022-06-25 05:31:10 +0100
commit8523738d6da11143cf18c9f042440c2bf14259e8 (patch)
tree9c88a94be09a048ffdecb93288d782ac5c34e9e5 /mail-client/alpine
parentnet-ftp/ftp: fix musl build; modernise (diff)
downloadgentoo-8523738d6da11143cf18c9f042440c2bf14259e8.tar.gz
gentoo-8523738d6da11143cf18c9f042440c2bf14259e8.tar.bz2
gentoo-8523738d6da11143cf18c9f042440c2bf14259e8.zip
mail-client/alpine: add version 2.26
Co-authored-by: CFuga <cfuga@cfuga.mx> Closes: https://bugs.gentoo.org/850781 Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/25856 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client/alpine')
-rw-r--r--mail-client/alpine/Manifest2
-rw-r--r--mail-client/alpine/alpine-2.26.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index c0e22786c7d9..d00d09f2c8bf 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -2,3 +2,5 @@ DIST alpine-2.25-chappa-11.patch.gz 172996 BLAKE2B b6fe190d8f95ffa9d851d4760517c
DIST alpine-2.25-chappa.patch.gz 172963 BLAKE2B 5e306325beb46fd2f716620794894f563b93e116693a1af050ea5f61c203350d2aa72b67d7f66acc748caea6a73bdef85f45324eb01edf8a6035b07f8a50e2bb SHA512 b88ca58e42a72b2b92cf28e4cae492a5ee75d534821046645fcc358833e87287fc707d5bec5c3508942a0ef1ecffe64916f00f1a01e430048384838e5ca40358
DIST alpine-2.25-ssl.patch 5431 BLAKE2B 0cf2fcb682fbee41aa988ff089c16b75ebd9bee321c1c130d0b5136e5ca521bded7e9a97cd3ade1c86b17e72136264d4405cc36427a347c9bee84ee8a64548d4 SHA512 698d2a3c3b7b588fe3fcfe0291f0aab05c42b5ea80de1f210c1985082651329b80447de4e8057bc7e962fe8ed5175ea8132bad413c02fb1f0cc67c84e9420642
DIST alpine-2.25.tar.xz 7495372 BLAKE2B ce2587a309c87ba527d51c360ee0d9627453cce6585631f569eb26db04aa6c5cddb7c9599478092447a040c43e9234e78a942fef4b1186d07c608163f96236be SHA512 76c214cf66f4ac7af3de40357ad3a592ff2a119e327e5f6c256125b7865d46b09197435fe6ac8077ab7a498e4821925939f3f902431ca77baa786e149466a193
+DIST alpine-2.26-chappa-5.patch.gz 173031 BLAKE2B 8719d37fde313e190608489e6191d4f0456f8a00ea267712e1c078ab1bbd3a8542bab3cf498faa1482fde386c24bf5335c54c39595ffb7fb019d13e975bf697a SHA512 aa979825367b309d5726055620c6f8f3effff954863e648de25f768ffbc175c3f91c8d1917e89116f35195a5ae266a9dcac51eb7f744f119ad848ddc0d10b8cc
+DIST alpine-2.26.tar.xz 7517628 BLAKE2B fe156974462dd566ac3fbe25cc54a1b2a480b3af46c8356356a97426f3e42495853efdbfeedc6173537dc150d90592c3fd9109e7d37f16738922a4205fd2f9df SHA512 359b5cb30be78a341b76c0475a2d5268b643788f14c9b5b9457af6748034e1d2e70fd7ddf59e5c59ad596a36d8a10afa9c41cbd74241c780b8575d8186168fd2
diff --git a/mail-client/alpine/alpine-2.26.ebuild b/mail-client/alpine/alpine-2.26.ebuild
new file mode 100644
index 000000000000..c06917b3931e
--- /dev/null
+++ b/mail-client/alpine/alpine-2.26.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="https://alpineapp.email/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa-5.patch"
+SRC_URI="https://alpineapp.email/alpine/release/src/${P}.tar.xz
+ chappa? ( https://alpineapp.email/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+chappa ipv6 kerberos ldap nls onlyalpine passfile smime ssl threads"
+
+DEPEND="sys-libs/ncurses:=
+ virtual/libcrypt:=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap:= )
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_with threads pthread)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if has_version "app-text/hunspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/hunspell )
+ elif has_version "app-text/aspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/aspell )
+ fi
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR="$(tc-getAR)"
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+ dodoc NOTICE README*
+ dodoc doc/brochure.txt
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+}
+
+pkg_postinst() {
+ optfeature "Spell checking" app-text/hunspell app-text/aspell
+}