summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/claws-mail-acpi-notifier
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/claws-mail-acpi-notifier')
-rw-r--r--mail-client/claws-mail-acpi-notifier/Manifest1
-rw-r--r--mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.28.ebuild43
-rw-r--r--mail-client/claws-mail-acpi-notifier/metadata.xml9
3 files changed, 53 insertions, 0 deletions
diff --git a/mail-client/claws-mail-acpi-notifier/Manifest b/mail-client/claws-mail-acpi-notifier/Manifest
new file mode 100644
index 000000000000..44eb0786defd
--- /dev/null
+++ b/mail-client/claws-mail-acpi-notifier/Manifest
@@ -0,0 +1 @@
+DIST acpi_notifier-1.0.28.tar.gz 416732 SHA256 826208e16dfb3c4da7c9bd87aa7ab399d058ac740309347f2bbc769368b1f55c SHA512 f4bc09cfe3db52912f367fe4b2e1f73baf5714842a5c0798897fea576a61110749689b836f55ce94d6e5702f75ebc3c89562751b9a39513f7f33f0161b8e3c40 WHIRLPOOL 11de745541a7e057b684ebb587c3e7ed489e7d63378cf610b3f1915cd01497e8c01824a147fed3c52c87dec3a99b11493d64c7b2c97284c35d1ae167e35054b4
diff --git a/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.28.ebuild b/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.28.ebuild
new file mode 100644
index 000000000000..f7bad8355fa4
--- /dev/null
+++ b/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.28.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RDEPEND="~mail-client/claws-mail-3.9.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+ local procfile
+ local message_shown=false
+
+ for procfile in ${PROC_IFACES}; do
+ if [[ -f ${procfile} ]]; then
+ elog "Make sure ${procfile} is writable by users of this plugin."
+ message_shown=true
+ fi
+ done
+}
diff --git a/mail-client/claws-mail-acpi-notifier/metadata.xml b/mail-client/claws-mail-acpi-notifier/metadata.xml
new file mode 100644
index 000000000000..df7c388592e4
--- /dev/null
+++ b/mail-client/claws-mail-acpi-notifier/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+</pkgmetadata>