summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/claws-mail-rssyl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/claws-mail-rssyl')
-rw-r--r--mail-client/claws-mail-rssyl/Manifest1
-rw-r--r--mail-client/claws-mail-rssyl/claws-mail-rssyl-0.34.ebuild37
-rw-r--r--mail-client/claws-mail-rssyl/files/claws-mail-rssyl-0.27-newline_hiccup.patch16
-rw-r--r--mail-client/claws-mail-rssyl/metadata.xml9
4 files changed, 63 insertions, 0 deletions
diff --git a/mail-client/claws-mail-rssyl/Manifest b/mail-client/claws-mail-rssyl/Manifest
new file mode 100644
index 000000000000..006c136969c8
--- /dev/null
+++ b/mail-client/claws-mail-rssyl/Manifest
@@ -0,0 +1 @@
+DIST rssyl-0.34.tar.gz 509269 SHA256 2e96a1cd6a1a5bb7f86cd2eb48f6e174665957fafe1f3b1e8361aac3bb967f79 SHA512 c8c719907b4403fa9386a054f503620b3151720c5c780c7740cd701def09d8ea0a1b723c6f56eeebf2c8df8474e43d6f5fe3fe70afbc8edcb66de6a383a7458a WHIRLPOOL 4626644130ceef91b8d589610397d597b26a1e6545660763b2cb52426bf47e0c41a80d60e84924af703f34131653d637a2d907975423e0f86160acf927181afd
diff --git a/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.34.ebuild b/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.34.ebuild
new file mode 100644
index 000000000000..7825813028cd
--- /dev/null
+++ b/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Read your favorite newsfeeds in Claws Mail. RSS 1.0, 2.0 and Atom feeds are currently supported"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE="nls"
+RDEPEND="~mail-client/claws-mail-3.9.0
+ net-misc/curl
+ dev-libs/libxml2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README || die
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-rssyl/files/claws-mail-rssyl-0.27-newline_hiccup.patch b/mail-client/claws-mail-rssyl/files/claws-mail-rssyl-0.27-newline_hiccup.patch
new file mode 100644
index 000000000000..8ed58ed681f7
--- /dev/null
+++ b/mail-client/claws-mail-rssyl/files/claws-mail-rssyl-0.27-newline_hiccup.patch
@@ -0,0 +1,16 @@
+Index: src/strreplace.c
+===================================================================
+RCS file: /home/claws-mail/plugins/rssyl/src/Attic/strreplace.c,v
+retrieving revision 1.1.2.7
+diff -u -B -r1.1.2.7 strreplace.c
+--- src/strreplace.c 28 Oct 2009 08:28:43 -0000 1.1.2.7
++++ src/strreplace.c 13 Jul 2010 19:23:32 -0000
+@@ -112,7 +112,7 @@
+ memset(new, '\0', strlen(str) + 1);
+
+ while( *c != '\0' ) {
+- if( !isspace(*c) || *c == ' ' ) {
++ if( !isspace(*c) || *c == ' ' || *c == '\n' ) {
+ *new_ptr = *c;
+ new_ptr++;
+ }
diff --git a/mail-client/claws-mail-rssyl/metadata.xml b/mail-client/claws-mail-rssyl/metadata.xml
new file mode 100644
index 000000000000..df7c388592e4
--- /dev/null
+++ b/mail-client/claws-mail-rssyl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+</pkgmetadata>