summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-21 08:33:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-21 08:33:30 +0100
commitd3421c07ae09c26536c7300bca72b07490425802 (patch)
tree40a29d40e228d9679ddb831a6e104acc285038b1 /mail-client/claws-mail/files
parentmail-client/claws-mail: Bump to version 3.13.1 (diff)
downloadgentoo-d3421c07ae09c26536c7300bca72b07490425802.tar.gz
gentoo-d3421c07ae09c26536c7300bca72b07490425802.tar.bz2
gentoo-d3421c07ae09c26536c7300bca72b07490425802.zip
mail-client/claws-mail: Removed old.
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'mail-client/claws-mail/files')
-rw-r--r--mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part1.patch149
-rw-r--r--mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part2.patch16
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch23
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch36
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.9.1_libsoup-check-fix.patch30
5 files changed, 0 insertions, 254 deletions
diff --git a/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part1.patch b/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part1.patch
deleted file mode 100644
index 0bdadd68da22..000000000000
--- a/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part1.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-Make combo search field work again.
-
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=455590
-Upstream commit: http://www.claws-mail.org/tracker/getpatchset.php?ver=3.9.0cvs8
---- src/advsearch.c 24 Oct 2012 07:48:24 -0000 1.1.2.7
-+++ src/advsearch.c 16 Nov 2012 13:10:05 -0000 1.1.2.8
-@@ -314,32 +314,6 @@
- return returnstr;
- }
-
--// --------------------------
--
--static gchar *expand_tag_search_string(const gchar *search_string)
--{
-- gchar *newstr = NULL;
-- gchar **words = search_string ? g_strsplit(search_string, " ", -1):NULL;
-- gint i = 0;
-- while (words && words[i] && *words[i]) {
-- g_strstrip(words[i]);
-- if (!newstr) {
-- newstr = g_strdup_printf("tag matchcase \"%s\"", words[i]);
-- } else {
-- gint o_len = strlen(newstr);
-- gint s_len = 17; /* strlen("|tag matchcase \"\"") */
-- gint n_len = s_len + strlen(words[i]);
-- newstr = g_realloc(newstr, o_len + n_len + 1);
-- strcpy(newstr + o_len, "|tag matchcase \"");
-- strcpy(newstr + o_len + (s_len - 1), words[i]);
-- strcpy(newstr + o_len + (n_len - 1), "\"");
-- }
-- i++;
-- }
-- g_strfreev(words);
-- return newstr;
--}
--
- static void prepare_matcher_extended(AdvancedSearch *search)
- {
- gchar *newstr = advsearch_expand_search_string(search->request.matchstring);
-@@ -350,19 +324,51 @@
- }
- }
-
-+#define debug_matcher_list(prefix, list) \
-+do { \
-+ gchar *str = list ? matcherlist_to_string(list) : g_strdup("(NULL)"); \
-+ \
-+ debug_print("%s: %s\n", prefix, str); \
-+ \
-+ g_free(str); \
-+} while(0)
-+
- static void prepare_matcher_tag(AdvancedSearch *search)
- {
-- char *newstr = expand_tag_search_string(search->request.matchstring);
-- search->predicate = matcher_parser_get_cond(newstr, &search->is_fast);
-- g_free(newstr);
-+ gchar **words = search->request.matchstring
-+ ? g_strsplit(search->request.matchstring, " ", -1)
-+ : NULL;
-+ gint i = 0;
-+
-+ if (search->predicate == NULL) {
-+ search->predicate = g_new0(MatcherList, 1);
-+ search->predicate->bool_and = FALSE;
-+ search->is_fast = TRUE;
-+ }
-+
-+ while (words && words[i] && *words[i]) {
-+ MatcherProp *matcher;
-+
-+ g_strstrip(words[i]);
-+
-+ matcher = matcherprop_new(MATCHCRITERIA_TAG, NULL,
-+ MATCHTYPE_MATCHCASE, words[i], 0);
-+
-+ search->predicate->matchers = g_slist_prepend(search->predicate->matchers, matcher);
-+
-+ i++;
-+ }
-+ g_strfreev(words);
- }
-
- static void prepare_matcher_header(AdvancedSearch *search, gint match_header)
- {
- MatcherProp *matcher;
-
-- if (search->predicate == NULL)
-+ if (search->predicate == NULL) {
- search->predicate = g_new0(MatcherList, 1);
-+ search->predicate->bool_and = FALSE;
-+ }
-
- matcher = matcherprop_new(match_header, NULL, MATCHTYPE_MATCHCASE,
- search->request.matchstring, 0);
-@@ -373,10 +379,18 @@
- static void prepare_matcher_mixed(AdvancedSearch *search)
- {
- prepare_matcher_tag(search);
-+ debug_matcher_list("tag matcher list", search->predicate);
-+
-+ /* we want an OR search */
-+ if (search->predicate)
-+ search->predicate->bool_and = FALSE;
-
- prepare_matcher_header(search, MATCHCRITERIA_SUBJECT);
-+ debug_matcher_list("tag + subject matcher list", search->predicate);
- prepare_matcher_header(search, MATCHCRITERIA_FROM);
-+ debug_matcher_list("tag + subject + from matcher list", search->predicate);
- prepare_matcher_header(search, MATCHCRITERIA_TO);
-+ debug_matcher_list("tag + subject + from + to matcher list", search->predicate);
- }
-
- static void prepare_matcher(AdvancedSearch *search)
-@@ -398,26 +412,32 @@
- switch (search->request.type) {
- case ADVANCED_SEARCH_SUBJECT:
- prepare_matcher_header(search, MATCHCRITERIA_SUBJECT);
-+ debug_matcher_list("subject search", search->predicate);
- break;
-
- case ADVANCED_SEARCH_FROM:
- prepare_matcher_header(search, MATCHCRITERIA_FROM);
-+ debug_matcher_list("from search", search->predicate);
- break;
-
- case ADVANCED_SEARCH_TO:
- prepare_matcher_header(search, MATCHCRITERIA_TO);
-+ debug_matcher_list("to search", search->predicate);
- break;
-
- case ADVANCED_SEARCH_TAG:
-- prepare_matcher_header(search, MATCHCRITERIA_TAG);
-+ prepare_matcher_tag(search);
-+ debug_matcher_list("tag search", search->predicate);
- break;
-
- case ADVANCED_SEARCH_MIXED:
- prepare_matcher_mixed(search);
-+ debug_matcher_list("mixed search", search->predicate);
- break;
-
- case ADVANCED_SEARCH_EXTENDED:
- prepare_matcher_extended(search);
-+ debug_matcher_list("extended search", search->predicate);
- break;
-
- default:
-
diff --git a/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part2.patch b/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part2.patch
deleted file mode 100644
index bb8a78aac832..000000000000
--- a/mail-client/claws-mail/files/claws-3.9.0_fix-search-field_part2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Make combo search field work again.
-
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=455590
-Upstream commit: http://www.claws-mail.org/tracker/getpatchset.php?ver=3.9.0cvs9
-
---- src/advsearch.c 16 Nov 2012 13:10:05 -0000 1.1.2.8
-+++ src/advsearch.c 16 Nov 2012 13:11:55 -0000 1.1.2.9
-@@ -368,6 +368,7 @@
- if (search->predicate == NULL) {
- search->predicate = g_new0(MatcherList, 1);
- search->predicate->bool_and = FALSE;
-+ search->is_fast = TRUE;
- }
-
- matcher = matcherprop_new(match_header, NULL, MATCHTYPE_MATCHCASE,
-
diff --git a/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch b/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch
deleted file mode 100644
index 82e13b25390f..000000000000
--- a/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Andrej Kacian <ticho@claws-mail.org>
-Date: Thu, 1 Jan 2015 22:36:36 +0000 (+0100)
-Subject: RSSyl: Fix handling of feeds with encodings unknown to expat. Turns out the only...
-X-Git-Url: http://git.claws-mail.org/?p=claws.git;a=commitdiff_plain;h=d05156031070efe6104695acad93aa879bc0f084
-
-RSSyl: Fix handling of feeds with encodings unknown to expat. Turns out the only thing missing was that HAVE_ICONV macro (from config.h) was not defined in parser.c, so our "unknown encoding" expat handler function did nothing. Fixes bug #3339.
----
-
-diff --git a/src/plugins/rssyl/libfeed/parser.c b/src/plugins/rssyl/libfeed/parser.c
-index bb0bb0d..14f4a36 100644
---- a/src/plugins/rssyl/libfeed/parser.c
-+++ b/src/plugins/rssyl/libfeed/parser.c
-@@ -17,6 +17,10 @@
- * Boston, MA 02111-1307, USA.
- */
-
-+#ifdef HAVE_CONFIG_H
-+# include <config.h>
-+#endif
-+
- #include <glib.h>
- #include <curl/curl.h>
- #include <expat.h>
diff --git a/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch b/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch
deleted file mode 100644
index 0abc3725a70b..000000000000
--- a/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-claws-mail 3.9.1 reproducible segfaults on exit when compiled with NNTP support.
-
-Apparently the pointer returned by account_get_list() is truncated to an integer due to a missing function definition:
-
-(gdb) r
-Starting program: /usr/local/bin/claws-mail
-[New LWP 101084]
-[New Thread 80ac06400 (LWP 101084)]
-
-Program received signal SIGSEGV, Segmentation fault.
-[Switching to Thread 80ac06400 (LWP 101084)]
-0x00000000005331f9 in nntp_disconnect_all (have_connectivity=1) at news.c:1418
-1418 for (list = account_get_list(); list != NULL; list = list->next) {
-(gdb) where
-#0 0x00000000005331f9 in nntp_disconnect_all (have_connectivity=1) at news.c:1418
-#1 0x0000000000669cf3 in nntp_main_done (have_connectivity=1) at nntp-thread.c:163
-#2 0x00000000004e59aa in exit_claws (mainwin=0x80acf23c0) at main.c:1811
-#3 0x00000000004e2627 in main (argc=1, argv=0x7fffffffd8b0) at main.c:1739
-(gdb) p list
-$1 = (GList *) 0xb836a00
-
-
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=469838
-Upstream bug: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2924
-Upstream fix: http://git.claws-mail.org/?p=claws.git;a=patch;h=8891f6e23e51b38c54c7b717fa0922cb101b76a2
-
---- a/src/news.c
-+++ b/src/news.c
-@@ -56,6 +56,7 @@
- #include "remotefolder.h"
- #include "alertpanel.h"
- #include "inc.h"
-+#include "account.h"
- #ifdef USE_GNUTLS
- # include "ssl.h"
- #endif
diff --git a/mail-client/claws-mail/files/claws-mail-3.9.1_libsoup-check-fix.patch b/mail-client/claws-mail/files/claws-mail-3.9.1_libsoup-check-fix.patch
deleted file mode 100644
index 3b5c452b7652..000000000000
--- a/mail-client/claws-mail/files/claws-mail-3.9.1_libsoup-check-fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-
-libsoup is not obligatory, but nonetheless a mandatory check existed.
-Fixed in releases >3.9.1
-
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=469014
-Upstream commit: http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=d04c724c9e74f7c5d1f247e41a21e472790d9992
-
-
---- configure.ac.orig
-+++ configure.ac
-@@ -1107,14 +1107,17 @@
- AC_SUBST(WEBKIT_CFLAGS)
-
- dnl libsoup ********************************************************************
--PKG_CHECK_MODULES(LIBSOUP, libsoup-2.4)
-+PKG_CHECK_MODULES(LIBSOUP, libsoup-2.4, HAVE_LIBSOUP=yes, HAVE_LIBSOUP=no)
-+if test x"$HAVE_LIBSOUP" = xyes; then
-+ AC_DEFINE(HAVE_LIBSOUP, 1, [Define if libsoup is available])
-+fi
- AC_SUBST(LIBSOUP_CFLAGS)
- AC_SUBST(LIBSOUP_LIBS)
-
- dnl libsoup-gnome **************************************************************
- PKG_CHECK_MODULES(LIBSOUP_GNOME, libsoup-gnome-2.4 >= 2.26, HAVE_LIBSOUP_GNOME=yes, HAVE_LIBSOUP_GNOME=no)
- if test x"$HAVE_LIBSOUP_GNOME" = xyes; then
-- AC_DEFINE(HAVE_LIBSOUP_GNOME, 1, [Define if libsoup is available])
-+ AC_DEFINE(HAVE_LIBSOUP_GNOME, 1, [Define if libsoup_gnome is available])
- fi
- AC_SUBST(LIBSOUP_GNOME_CFLAGS)
- AC_SUBST(LIBSOUP_GNOME_LIBS)