summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/drac/drac-1.12-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/drac/drac-1.12-r1.ebuild')
-rw-r--r--mail-client/drac/drac-1.12-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/mail-client/drac/drac-1.12-r1.ebuild b/mail-client/drac/drac-1.12-r1.ebuild
new file mode 100644
index 000000000000..ca6b3c64c6b4
--- /dev/null
+++ b/mail-client/drac/drac-1.12-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A robust implementation of POP-before-SMTP"
+HOMEPAGE="http://mail.cc.umanitoba.ca/drac/"
+SRC_URI="ftp://ftp.cc.umanitoba.ca/src/${PN}.tar.Z"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="x86 sparc ppc hppa ~amd64 ppc64"
+IUSE="debug"
+
+DEPEND="virtual/mta
+ >=sys-libs/db-3.2.9
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ >=net-nds/portmap-5b-r6"
+
+S="${WORKDIR}"
+
+src_compile() {
+ local mysed
+ if use debug ; then
+ mysed="s:^CFLAGS.*:CFLAGS = \$(DEFS) -g ${CFLAGS}:"
+ else
+ mysed="s:^CFLAGS.*:CFLAGS = \$(DEFS) ${CFLAGS}:"
+ fi
+
+ sed -e "s:^INSTALL = .*:INSTALL = /usr/bin/install:" \
+ -e "s:^EBIN = .*:EBIN = /usr/sbin:" \
+ -e "s:^MAN = .*:MAN = /usr/share/man/man:" \
+ -e "s:^DEFS = .*:DEFS = -DSOCK_RPC -DFCNTL_LOCK -DGETHOST -DDASH_C:" \
+ -e "s:^CC = .*:CC = $(tc-getCC):" \
+ -e "s:^LDLIBS = .*:LDLIBS = -ldb:" \
+ -e "s:^TSTLIBS = .*:TSTLIBS = -L. -ldrac:" \
+ -e "s:^RPCGENFLAGS = .*:RPCGENFLAGS = -C -I:" \
+ -e "s:^MANADM = .*:MANADM = 8:" \
+ -e "${mysed}" \
+ -i Makefile || die "sed failed"
+
+ # Parallel build does not work.
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ newsbin rpc.dracd dracd
+ dosbin "${FILESDIR}/drac_rotate"
+
+ dolib.a libdrac.a
+
+ newinitd "${FILESDIR}/dracd.rc6" dracd
+
+ dodoc Changes COPYRIGHT INSTALL PORTING README
+ newman rpc.dracd.1m dracd.8
+ doman dracauth.3
+
+ keepdir /var/lib/drac
+ fowners mail:mail /var/lib/drac
+ fperms 750 /var/lib/drac
+}
+
+pkg_postinst() {
+ elog "After configuring your IMAP/POP server for DRAC, and starting the"
+ elog "dracd server (e.g. by running /etc/init.d/dracd start) you can"
+ elog "set up your MTA to check for authenticated hosts in:"
+ elog " /var/lib/drac/drac"
+ elog "Please see the MTA documentation for more details."
+ echo
+}