summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-29 11:12:54 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-29 11:27:25 +0300
commit498eeae0f6432454823cfda9225edd5e93fd8676 (patch)
tree8c782fae0a4cacb07df1da32ce0ec8b95e6beab7 /mail-client/geary
parentmail-client/balsa: security cleanup (diff)
downloadgentoo-498eeae0f6432454823cfda9225edd5e93fd8676.tar.gz
gentoo-498eeae0f6432454823cfda9225edd5e93fd8676.tar.bz2
gentoo-498eeae0f6432454823cfda9225edd5e93fd8676.zip
mail-client/geary: security bump to 3.36.3.1
Bug: https://bugs.gentoo.org/739174 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'mail-client/geary')
-rw-r--r--mail-client/geary/Manifest1
-rw-r--r--mail-client/geary/geary-3.36.3.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/mail-client/geary/Manifest b/mail-client/geary/Manifest
index f55f4210f46e..fe7f1283dbd9 100644
--- a/mail-client/geary/Manifest
+++ b/mail-client/geary/Manifest
@@ -1 +1,2 @@
DIST geary-3.36.2.tar.xz 2416928 BLAKE2B 983357ffe5e6be637d992a530d8bee3ff90257620a73df628b6e36f18dc021d97eba6f2ef59290d3ab8e7c781a39c50b67e42104d51f0ad51e65f2de00c95352 SHA512 a3cca301a3668eb2e70f8bfc147abef9088de4e822efab4ecc44830fbc394265d1fa37267a1f8fa97b6e8d1ac8a8adb76e5dd9e509490ac567e05bd243e8ea20
+DIST geary-3.36.3.1.tar.xz 2426684 BLAKE2B 0e52b11d515c072c610f60070f3634f98a8f89f8580ee9e59a6eca8144680c616c0984d31ad6f3a0044c08fe6a1f2b45065059561c20c9c796403d2eb088f567 SHA512 c1c659cbadbdcb4cedefb0db7c5548af55cd07c30bc4acafb96e69faa6b730a2c5ba06abceedc409fddd9768249600ebc7643b9cfe2175e6d4d2d7926a55dbb6
diff --git a/mail-client/geary/geary-3.36.3.1.ebuild b/mail-client/geary/geary-3.36.3.1.ebuild
new file mode 100644
index 000000000000..071e4c68efe2
--- /dev/null
+++ b/mail-client/geary/geary-3.36.3.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+VALA_MAX_API_VERSION="0.48" # fails tests with 0.50 in v3.36.3.1 - https://gitlab.gnome.org/GNOME/geary/-/issues/958
+
+inherit gnome.org gnome2-utils meson vala virtualx xdg
+
+DESCRIPTION="A lightweight, easy-to-use, feature-rich email client"
+HOMEPAGE="https://wiki.gnome.org/Apps/Geary"
+
+LICENSE="LGPL-2.1+ BSD-2 CC-BY-3.0 CC-BY-SA-3.0" # code is LGPL-2.1+, BSD-2 for bundled snowball-stemmer, CC licenses for some icons
+SLOT="0"
+
+IUSE="ytnef"
+
+KEYWORDS="~amd64 ~x86"
+
+# for now both enchants work, but ensuring enchant:2
+
+# >=webkit-gtk-2.26.4-r1 and >=gspell-1.7 dep to ensure all libraries used use enchant:2
+DEPEND="
+ >=dev-libs/glib-2.60.4:2
+ >=x11-libs/gtk+-3.24.7:3
+ >=net-libs/webkit-gtk-2.26.4-r1:4=
+ >=dev-libs/gmime-3.2.4:3.0
+ >=dev-db/sqlite-3.24:3
+
+ app-text/enchant:2
+ >=dev-libs/folks-0.11:0
+ >=app-crypt/gcr-3.10.1:0=
+ >=dev-libs/libgee-0.8.5:0.8=
+ net-libs/gnome-online-accounts
+ >=app-text/gspell-1.7:=
+ app-text/iso-codes
+ >=dev-libs/json-glib-1.0
+ >=gui-libs/libhandy-0.0.10:0.0=
+ >=dev-libs/libpeas-1.24.0
+ >=app-crypt/libsecret-0.11
+ >=net-libs/libsoup-2.48:2.4
+ >=sys-libs/libunwind-1.1:0
+ >=dev-libs/libxml2-2.7.8:2
+ ytnef? ( >=net-mail/ytnef-1.9.3 )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ >=dev-libs/appstream-glib-0.7.10
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ $(vala_depend)
+ x11-libs/gtk+:3[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ dev-libs/gmime:3.0[vala]
+ app-crypt/gcr:0[introspection,vala]
+ dev-libs/libgee:0.8[introspection]
+ app-text/gspell[vala]
+ gui-libs/libhandy:0.0[vala]
+ app-crypt/libsecret[introspection,vala]
+ net-libs/libsoup:2.4[introspection,vala]
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcontractor=false
+ -Dlibunwind_optional=false # TODO: Automagical if optional=true
+ -Dpoodle=true
+ $(meson_use ytnef tnef-support)
+ -Dvaladoc=false
+ -Dprofile=default
+ -Drevno="${PR}"
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}