summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/mailx-support/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/mailx-support/files')
-rw-r--r--mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch66
-rw-r--r--mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch9
-rw-r--r--mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch18
3 files changed, 93 insertions, 0 deletions
diff --git a/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
new file mode 100644
index 000000000000..829b85820488
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
@@ -0,0 +1,66 @@
+--- - 2003-02-15 23:35:46.000000000 +0800
++++ locking.c 2003-02-15 23:19:11.000000000 +0800
+@@ -45,6 +45,7 @@
+ #include <stdarg.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ static char lpath[MAXPATHLEN];
+
+@@ -93,7 +94,7 @@
+ }
+ goto again;
+ }
+- if ((lfd = open(lpath, O_CREAT|O_WRONLY|O_EXCL|O_EXLOCK,
++ if ((lfd = open_with_exlock(lpath, O_CREAT|O_WRONLY|O_EXCL,
+ S_IRUSR|S_IWUSR)) != -1)
+ break;
+ again:
+@@ -104,7 +105,7 @@
+ return(-1);
+ }
+ if (tries > 9 &&
+- (lfd = open(lpath, O_WRONLY|O_EXLOCK, 0)) != -1) {
++ (lfd = open_with_exlock(lpath, O_WRONLY, 0)) != -1) {
+ if (fstat(lfd, &fsb) != -1 &&
+ lstat(lpath, &sb) != -1) {
+ if (fsb.st_dev == sb.st_dev &&
+@@ -169,3 +170,4 @@
+ if (isfatal)
+ exit(1);
+ }
++
+--- - 2003-02-15 23:37:13.000000000 +0800
++++ mail.local.c 2003-02-15 23:20:50.000000000 +0800
+@@ -66,6 +66,7 @@
+ #include <string.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ int
+ main(int argc, char *argv[])
+@@ -218,7 +219,7 @@
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ if (errno == EEXIST) {
+ /* file appeared since lstat */
+@@ -244,7 +245,7 @@
+ merr(NOTFATAL, "%s: linked or special file", path);
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+@@ -340,3 +341,4 @@
+ {
+ merr(FATAL, "usage: mail.local [-lL] [-f from] user ...");
+ }
++
diff --git a/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch b/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch
new file mode 100644
index 000000000000..b3b871b43a51
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch
@@ -0,0 +1,9 @@
+diff -Naur mailx-support-20060102.orig/open_with_exlock.c mailx-support-20060102/open_with_exlock.c
+--- mailx-support-20060102.orig/open_with_exlock.c 2003-06-09 19:01:08.000000000 +0000
++++ mailx-support-20060102/open_with_exlock.c 2014-04-01 12:17:31.830213927 +0000
+@@ -1,4 +1,5 @@
+ #include <fcntl.h>
++#include <sys/file.h>
+
+ int open_with_exlock(const char *path, int flags, mode_t mode)
+ {
diff --git a/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch b/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch
new file mode 100644
index 000000000000..42aa56948c7a
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch
@@ -0,0 +1,18 @@
+Index: mailx-support-20060102/Makefile
+===================================================================
+--- mailx-support-20060102.orig/Makefile
++++ mailx-support-20060102/Makefile
+@@ -17,10 +17,10 @@ clean:
+ ${RM} -f ${PRODUCTS} *.o
+
+ mail.local: mail.local.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${CFLAGS} -o $@ $^
+
+ lockspool: lockspool.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${BINDNOW_FLAGS} ${CFLAGS} -o $@ $^
+
+ .c.o:
+ ${CC} ${CFLAGS} -c -o $@ $^
+