summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2021-05-13 12:26:24 -0600
committerSam James <sam@gentoo.org>2021-05-14 01:22:38 +0100
commit12abfe9e49c4d244e9d4e237f1329356880e1bdf (patch)
tree020c75799df3cf6fd10113c30c3bd51dc491ea8a /mail-client/neomutt
parentdev-lang/qu-prolog: fix PythonMissingDeps (diff)
downloadgentoo-12abfe9e49c4d244e9d4e237f1329356880e1bdf.tar.gz
gentoo-12abfe9e49c4d244e9d4e237f1329356880e1bdf.tar.bz2
gentoo-12abfe9e49c4d244e9d4e237f1329356880e1bdf.zip
mail-client/neomutt: Do not call `cc`
Closes: https://bugs.gentoo.org/724716 Closes: https://github.com/gentoo/gentoo/pull/20796 Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client/neomutt')
-rw-r--r--mail-client/neomutt/neomutt-20210205-r1.ebuild4
-rw-r--r--mail-client/neomutt/neomutt-99999999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/mail-client/neomutt/neomutt-20210205-r1.ebuild b/mail-client/neomutt/neomutt-20210205-r1.ebuild
index 3c05cf9fd231..e8395c25d1e0 100644
--- a/mail-client/neomutt/neomutt-20210205-r1.ebuild
+++ b/mail-client/neomutt/neomutt-20210205-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
if [[ ${PV} =~ 99999999$ ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
@@ -106,7 +108,7 @@ src_configure() {
"$(usex test --testing --disable-testing)"
)
- econf CCACHE=none "${myconf[@]}"
+ econf CCACHE=none CC_FOR_BUILD=$(tc-getCC) "${myconf[@]}"
}
src_test() {
diff --git a/mail-client/neomutt/neomutt-99999999.ebuild b/mail-client/neomutt/neomutt-99999999.ebuild
index ac3c11deb6ff..2731fc6fe9ff 100644
--- a/mail-client/neomutt/neomutt-99999999.ebuild
+++ b/mail-client/neomutt/neomutt-99999999.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
if [[ ${PV} =~ 99999999$ ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
@@ -102,7 +104,7 @@ src_configure() {
"$(usex test --testing --disable-testing)"
)
- econf CCACHE=none "${myconf[@]}"
+ econf CCACHE=none CC_FOR_BUILD=$(tc-getCC) "${myconf[@]}"
}
src_test() {