summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/pinepgp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/pinepgp')
-rw-r--r--mail-client/pinepgp/Manifest1
-rw-r--r--mail-client/pinepgp/files/pinepgp-0.18.0-makefile-sed-fix.patch87
-rw-r--r--mail-client/pinepgp/metadata.xml5
-rw-r--r--mail-client/pinepgp/pinepgp-0.18.0-r1.ebuild27
4 files changed, 120 insertions, 0 deletions
diff --git a/mail-client/pinepgp/Manifest b/mail-client/pinepgp/Manifest
new file mode 100644
index 000000000000..2c5f75fd5fe3
--- /dev/null
+++ b/mail-client/pinepgp/Manifest
@@ -0,0 +1 @@
+DIST pinepgp-0.18.0.tar.gz 38103 RMD160 1990bdc56460cbafe8b62cffaf5520038fe910ce SHA1 d80495079f398d60a7c6262f0778fbf0db6ecaf2 SHA256 2917ed5734b2c2e70cd8d944537cb0280f7cdfa34fcd64121f41bb4c37c7d6d9
diff --git a/mail-client/pinepgp/files/pinepgp-0.18.0-makefile-sed-fix.patch b/mail-client/pinepgp/files/pinepgp-0.18.0-makefile-sed-fix.patch
new file mode 100644
index 000000000000..fe9f8d55a0dc
--- /dev/null
+++ b/mail-client/pinepgp/files/pinepgp-0.18.0-makefile-sed-fix.patch
@@ -0,0 +1,87 @@
+diff -Naur pinepgp-0.18.0-orig/Makefile.in pinepgp-0.18.0/Makefile.in
+--- pinepgp-0.18.0-orig/Makefile.in 2002-05-03 15:30:07.000000000 +0200
++++ pinepgp-0.18.0/Makefile.in 2006-11-16 00:30:27.000000000 +0100
+@@ -44,52 +44,52 @@
+ all: $(SOURCES) $(BUILD_FILTERS)
+
+ $(SOURCES): $(SOURCES:%=%.in)
+- $(CAT) $(@).in | $(SED) -e 's%\@SED\@%$(SED)%;\
+- s%\@CAT\@%$(CAT)%;\
+- s%\@RM\@%$(RM)%;\
+- s%\@MKTEMP\@%$(MKTEMP)%;\
+- s%\@BASH\@%$(BASH)%;\
+- s%\@bindir\@%$(bindir)%;\
+- s%\@tmpdir\@%$(tmpdir)%' > $(@)
++ $(CAT) $(@).in | $(SED) -e 's%\@SED\@%$(SED)%'\
++ -e 's%\@CAT\@%$(CAT)%'\
++ -e 's%\@RM\@%$(RM)%'\
++ -e 's%\@MKTEMP\@%$(MKTEMP)%'\
++ -e 's%\@BASH\@%$(BASH)%'\
++ -e 's%\@bindir\@%$(bindir)%'\
++ -e 's%\@tmpdir\@%$(tmpdir)%' > $(@)
+ chmod 755 $(@)
+
+ pinegpg: pinegpgp
+- $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename=GnuPG%;\
+- s%^ces=.*%ces="$(GPG) -at -s"%;\
+- s%^cee=.*%cee="$(GPG) -at -e"%;\
+- s%^cese=.*%cese="$(GPG) -at -se"%;\
+- s%^cec=.*%cec="\$(GPG)"%;\
+- s%^cefp=.*%cefp=gpg%' > $(@).c
++ $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename=GnuPG%'\
++ -e 's%^ces=.*%ces="$(GPG) -at -s"%'\
++ -e 's%^cee=.*%cee="$(GPG) -at -e"%'\
++ -e 's%^cese=.*%cese="$(GPG) -at -se"%'\
++ -e 's%^cec=.*%cec="\$(GPG)"%'\
++ -e 's%^cefp=.*%cefp=gpg%' > $(@).c
+ $(CPP) -DGPG $(BUILD_FLAGS) $(@).c | $(GREP) -v "^# .* .*" > $(@)
+ chmod 755 $(@)
+
+ pinepgp26x: pinegpgp
+- $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 2.6.x"%;\
+- s%^ces=.*%ces="\$(PGP) -fat -s"%;\
+- s%^cee=.*%cee="\$(PGP) -fat -e"%;\
+- s%^cese=.*%cese="\$(PGP) -fat -se"%;\
+- s%^cec=.*%cec="\$(PGP) -f"%;\
+- s%^cefp=.*%cefp=pgp26x%' > $(@).c
++ $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 2.6.x"%'\
++ -e 's%^ces=.*%ces="\$(PGP) -fat -s"%'\
++ -e 's%^cee=.*%cee="\$(PGP) -fat -e"%'\
++ -e 's%^cese=.*%cese="\$(PGP) -fat -se"%'\
++ -e 's%^cec=.*%cec="\$(PGP) -f"%'\
++ -e 's%^cefp=.*%cefp=pgp26x%' > $(@).c
+ $(CPP) -DPGP26X $(BUILD_FLAGS) $(@).c | $(GREP) -v "^# .* .*" > $(@)
+ chmod 755 $(@)
+
+ pinepgp5x: pinegpgp
+- $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 5.x"%;\
+- s%^ces=.*%ces="$(PGP5S) -fat"%;\
+- s%^cee=.*%cee="$(PGP5E) -fat"%;\
+- s%^cese=.*%cese="$(PGP5E) -fat -s"%;\
+- s%^cec=.*%cec="$(PGP5V) -f"%;\
+- s%^cefp=.*%cefp=pgp26x%' > $(@).c
++ $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 5.x"%'\
++ -e 's%^ces=.*%ces="$(PGP5S) -fat"%'\
++ -e 's%^cee=.*%cee="$(PGP5E) -fat"%'\
++ -e 's%^cese=.*%cese="$(PGP5E) -fat -s"%'\
++ -e 's%^cec=.*%cec="$(PGP5V) -f"%'\
++ -e 's%^cefp=.*%cefp=pgp26x%' > $(@).c
+ $(CPP) -DPGP5X $(BUILD_FLAGS) $(@).c | $(GREP) -v "^# .* .*" > $(@)
+ chmod 755 $(@)
+
+ pinepgp65x: pinegpgp
+- $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 6.5.x"%;\
+- s%^ces=.*%ces="\$(PGP6) -fat -s -u $$USER"%;\
+- s%^cee=.*%cee="\$(PGP6) -fat -e -u $$USER"%;\
+- s%^cese=.*%cese="\$(PGP6) -fat -se -u $$USER"%;\
+- s%^cec=.*%cec="\$(PGP6) -f -u $$USER"%;\
+- s%^cefp=.*%cefp=pgp65x%' > $(@).c
++ $(CAT) pinegpgp | $(SED) -e 's%^cename=.*%cename="PGP 6.5.x"%'\
++ -e 's%^ces=.*%ces="\$(PGP6) -fat -s -u $$USER"%'\
++ -e 's%^cee=.*%cee="\$(PGP6) -fat -e -u $$USER"%'\
++ -e 's%^cese=.*%cese="\$(PGP6) -fat -se -u $$USER"%'\
++ -e 's%^cec=.*%cec="\$(PGP6) -f -u $$USER"%'\
++ -e 's%^cefp=.*%cefp=pgp65x%' > $(@).c
+ $(CPP) -DPGP65X $(BUILD_FLAGS) $(@).c | $(GREP) -v "^# .* .*" > $(@)
+ chmod 755 $(@)
+
diff --git a/mail-client/pinepgp/metadata.xml b/mail-client/pinepgp/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/mail-client/pinepgp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>
diff --git a/mail-client/pinepgp/pinepgp-0.18.0-r1.ebuild b/mail-client/pinepgp/pinepgp-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..c32067c67008
--- /dev/null
+++ b/mail-client/pinepgp/pinepgp-0.18.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Use GPG/PGP with Pine"
+HOMEPAGE="http://www.megaloman.com/~hany/software/pinepgp/"
+SRC_URI="http://www.megaloman.com/~hany/_data/pinepgp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="|| ( mail-client/alpine mail-client/pine )
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile-sed-fix.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install problem"
+ dodoc ChangeLog README
+}