summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-11 12:50:56 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-11 12:52:09 +0200
commit08d3ce13b04dd7fb41103d143630e2751f36faf8 (patch)
tree6eff7f8bf30f8383ef0f1a30d037b77ea1a00282 /mail-client
parentdev-lang/swi-prolog: remove old development versions (diff)
downloadgentoo-08d3ce13b04dd7fb41103d143630e2751f36faf8.tar.gz
gentoo-08d3ce13b04dd7fb41103d143630e2751f36faf8.tar.bz2
gentoo-08d3ce13b04dd7fb41103d143630e2751f36faf8.zip
mail-client/roundcube: bump to v1.311
Bug: https://bugs.gentoo.org/720876 Closes: https://bugs.gentoo.org/720144 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.3.11.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index fcf158db2a95..7731196a3315 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1,5 @@
DIST roundcubemail-1.3.10-complete.tar.gz 5495189 BLAKE2B d2b6d7ac28fc609ab3d7275019796c73859a4ecdbbe17018c8ed9d1c702a1563e59429bfb47d9878869d7948ed1051c4a9caaac0d83b26b0a88e293e31bb27d6 SHA512 8fffa16abda87d29081d1afedbf1d9e4862b8b1864785101d422e62048ca7f365c3708e8a76b4a37f716109230943bb9f03a5faa0cf3c3963fa5454207e00c49
+DIST roundcubemail-1.3.11-complete.tar.gz 5492078 BLAKE2B 465d2ecf842c7393bc0bdf8b43d5e63b58e25ea360c1a8c93ccda8b350642dec34512090469720083d30212a31c3d9d7d56aa7df55cae167154bea96cdd19dc3 SHA512 5eb200b58bb289af7432c685eb1feaa2f8fbea56413efd05cf7cf9a4369551d889200b583f04c01c092d8d4c551151fe1051fbe901b02fa2fb26f7ade1c571a2
DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57baa18d1f057fdd2eb0f872f3cef1053847861998f8c6551fc17506ae365086ed1f86c3ee9e73a96adb2e43c6c32025e7afaf63710 SHA512 34dc9205cd93be6d6551086f4d22654dad7213b4b09000dc4def08357acdc634744ce1f560144a3d3b46e936258e90482e77fc4c691a55c205bcfdfe3745441e
DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
DIST roundcubemail-1.4.0-complete.tar.gz 6997256 BLAKE2B b19a2d049512ceb53b3844f4680ed061044d2d142bef322c067b381e3be57ecb3181cac4f2492a162da1417fefb4028c36d34dae4bf9064c97568f681bd0c78b SHA512 274372793f1f3af761702f8972f6360f8c8e64a705ff96f1432f6a520d24c9ca0e8ccc3933f26433f1c864bd6c381066fc9eb48bf97e9497b4cbff855412d811
diff --git a/mail-client/roundcube/roundcube-1.3.11.ebuild b/mail-client/roundcube/roundcube-1.3.11.ebuild
new file mode 100644
index 000000000000..af45b42575c0
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.3.11.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+# :TODO: Support "endriod/qrcode: ~1.6.5" dep (ebuild needed)
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.1.0
+ >=dev-php/PEAR-Mail_Mime-1.10.0
+ >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+ >=dev-php/PEAR-Net_IDNA2-0.2.0
+ >=dev-php/PEAR-Net_SMTP-1.7.1
+ virtual/httpd-php
+ change-password? (
+ >=dev-php/PEAR-Net_Socket-1.2.1
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ >=dev-php/PEAR-Crypt_GPG-1.6.0
+ app-crypt/gnupg
+ )
+ ldap? (
+ >=dev-php/PEAR-Net_LDAP2-2.2.0
+ dev-php/PEAR-Net_LDAP3
+ )
+ managesieve? ( >=dev-php/PEAR-Net_Sieve-1.4.0 )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Redundant. (Bug #644896)
+ rm -r vendor/pear || die
+
+ # Remove references to PEAR. (Bug #650910)
+ cp "${FILESDIR}"/roundcube-1.3.7-pear-removed-installed.json \
+ vendor/composer/installed.json \
+ || die
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}