summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-11 23:57:20 +0000
committerSam James <sam@gentoo.org>2021-02-12 15:10:13 +0000
commit0e8f165b487aa8cb01e0ffa44ac94f229c454268 (patch)
tree8d87ea6b345777c428940034302b8f0bd44fc173 /mail-client
parentapp-antivirus/fangfrisch: Remove obsolete ebuild (diff)
downloadgentoo-0e8f165b487aa8cb01e0ffa44ac94f229c454268.tar.gz
gentoo-0e8f165b487aa8cb01e0ffa44ac94f229c454268.tar.bz2
gentoo-0e8f165b487aa8cb01e0ffa44ac94f229c454268.zip
mail-client/mutt-wizard: version bump to 3.2.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19421 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt-wizard/Manifest1
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-3.2.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/Manifest b/mail-client/mutt-wizard/Manifest
index 062ed1c019f6..92b86702b9a2 100644
--- a/mail-client/mutt-wizard/Manifest
+++ b/mail-client/mutt-wizard/Manifest
@@ -1 +1,2 @@
DIST mutt-wizard-3.1.1.tar.gz 33346 BLAKE2B 0f4d8e973fedc0d102242a06922627039f4244ad9fc901d6e3d7235089164c3a7f255587978c95762242146441d8a48f57401e9ec86754194b531d38f0074652 SHA512 b385bab603eff561bca8aade49f3d11a4ac031cbceb4a64d80be9b591dc34757a05bb3c56c23ec9f1942392833725872d4871bf34964c4503bc01d5223286ddb
+DIST mutt-wizard-3.2.1.tar.gz 33468 BLAKE2B 60087ca8b6cfe2f69e1f078942ef24be8d387fbadcacfdf0105e6ee6df315a57fb21320635b685dad5e5e15860adb9cef147dc9b029d77bfdfd196f219faca91 SHA512 bcd72a937d142bddb2c3b55bd6f5442a96421850ef57931e147aad8feefd6752de90cc7076802f5c806edc9a530e05a24576e33f301196eee707a75aa16279a6
diff --git a/mail-client/mutt-wizard/mutt-wizard-3.2.1.ebuild b/mail-client/mutt-wizard/mutt-wizard-3.2.1.ebuild
new file mode 100644
index 000000000000..dc33b5c31681
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-3.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}