summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2020-08-11 09:54:30 -0400
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 21:19:59 +0200
commit19bf444bb00c60a3af82c5efcea93a0624b98887 (patch)
tree8f55d1d29d53a3eb5a8f4d63b9c41a03a55307fa /mail-client
parentmedia-gfx/graphviz: Drop old (diff)
downloadgentoo-19bf444bb00c60a3af82c5efcea93a0624b98887.tar.gz
gentoo-19bf444bb00c60a3af82c5efcea93a0624b98887.tar.bz2
gentoo-19bf444bb00c60a3af82c5efcea93a0624b98887.zip
mail-client/roundcube: Bump to 1.4.8
Just a copy of 1.4.7's ebuild. Bug: https://bugs.gentoo.org/736742 Closes: https://github.com/gentoo/gentoo/pull/17078 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.4.8.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index d7076af22478..1b65ea4d495f 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,2 +1,3 @@
DIST roundcubemail-1.4.6-complete.tar.gz 7031573 BLAKE2B 541147faeb2fafbf15fd3a4f42a5ecbb642113f02ea9135c91d3b359ec4582e490b80b2e20efa1f6afe8c35e5afe2263682a717a5342198a9eabb7e555e302bb SHA512 e86763ced58cfa8174f71d33ae45cd62f26a58853b9361b800003fa5bf883a4106c957f66b6b17b03172a3ee595ca74d7c19ac38e449a23377defd77cf555742
DIST roundcubemail-1.4.7-complete.tar.gz 7031947 BLAKE2B eec5295c68b7b8f7a652bc6e4ddbb56fbf68e9d1fc01ed75ac8ec33434f299b02e46a8b7f21c56e87ebf9cb0ffa8d105e5e3d9fbcaaab26844c7ed439908bea4 SHA512 d668075c1fb1ac48931a82ca67b4ebeed6f1d1e82a336901f79967cb2eb91979fc7bb46d4895558f8e64f89f963002efc7c1ad23b93c52a252ce1a7aa04b678a
+DIST roundcubemail-1.4.8-complete.tar.gz 7032822 BLAKE2B 61c5329d9abe65baba3274d3cb9a6a435f886a0196c2881153da473eb415ad4c63dfdab49c67c75a2fd92ff55f9e6da7bdfcece7041ce408b2be628da47045d4 SHA512 8b7734cdec95954b7e18a0e44957da6ef74b5b0c3d28a1449e8634faa230844f5e0c28954245641758f8b2d9102aa32f279765ed3dfa20fa7b00dee4e5347362
diff --git a/mail-client/roundcube/roundcube-1.4.8.ebuild b/mail-client/roundcube/roundcube-1.4.8.ebuild
new file mode 100644
index 000000000000..6d3b3ede4e45
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.4.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}