summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-07-29 09:54:27 -0400
committerCraig Andrews <candrews@gentoo.org>2022-07-29 09:54:52 -0400
commit25ac52c996df6f972269534fbb42ccc86e1b25c3 (patch)
tree3f26c16268395f46e3b65e8d7da14ac4ee71592f /mail-client
parentsys-kernel/gentoo-sources: drop 5.18.10 (diff)
downloadgentoo-25ac52c996df6f972269534fbb42ccc86e1b25c3.tar.gz
gentoo-25ac52c996df6f972269534fbb42ccc86e1b25c3.tar.bz2
gentoo-25ac52c996df6f972269534fbb42ccc86e1b25c3.zip
mail-client/roundcube: 1.6.0 version bump
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.6.0.ebuild97
-rw-r--r--mail-client/roundcube/roundcube-9999.ebuild2
3 files changed, 99 insertions, 1 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 54c515c650b6..b79283e1d812 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -5,3 +5,4 @@ DIST roundcubemail-1.5.2-complete.tar.gz 7852981 BLAKE2B 36920aa30301b96e1157a58
DIST roundcubemail-1.5.3-complete.tar.gz 7857655 BLAKE2B 46e34d706b9b2a425e3c9bba2f05e5b21d9c15b9e3031c49aa4df97fbd07f6b769c4784fe4f65cd1a21fe0270629f3573239ff1e82486c39abee9ae118540e4f SHA512 b43db6ffe129e8738b34e0f3dad6fec815e6be4dc41237f81bbb53ccfe56ac2d5b115edcef0a2587d4733f73b0951e740d94f0d314b324d4dd31c4563994aec1
DIST roundcubemail-1.6-beta-complete.tar.gz 5941128 BLAKE2B 2114a683cbf0c4ec6f5ba0b4d5eebb0a1f96121724861c1b1b5ce30f6b3a8fae02693878cae168af3d7f906a705814233aef024ddbc24d807ccd089f24b63fe1 SHA512 8a8bc9749203980d33ede7b221b96e0990b4afbe41db65fca74f0a49334adcae717306d4fe8fe1a5c938bf9fbcb5c4745d4d67bc5a587503aa3a2e9cb8f6384b
DIST roundcubemail-1.6-rc-complete.tar.gz 5961003 BLAKE2B a21a42f69c223eb50b38f6d02ab69ebe3cf55cc2848fc49cc0e238eead5f19751801654c0b5fb6954022d9b24562c04ba085bf668591a5b7ff7b306d3a950d1c SHA512 f12f7858b19ce16613ed02a8b4cf7b4fe16753454b7c4cf4e92bbb2d11de4ba1e00b09ba70b387133613967654aadaaf09167ed16c54809885eb48adcf54de5f
+DIST roundcubemail-1.6.0-complete.tar.gz 5970153 BLAKE2B 2e8766f9b99c36c9111768fc9bc5fca9811c59f82b740d66cd03da939c15f32467750d752e60b8c0def059f0b2f25a208460dc688fe595f971babdc9923f5e4e SHA512 821733778085c670caeed6bed515e542841920dccc21e2ca97088e1f77a302b6961234d6ee5bcfbda797470889747a3be2c6d13cc5016615c8919c7ea064108c
diff --git a/mail-client/roundcube/roundcube-1.6.0.ebuild b/mail-client/roundcube/roundcube-1.6.0.ebuild
new file mode 100644
index 000000000000..30c03bb63b3f
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}
diff --git a/mail-client/roundcube/roundcube-9999.ebuild b/mail-client/roundcube/roundcube-9999.ebuild
index 44d89c9d3634..30c03bb63b3f 100644
--- a/mail-client/roundcube/roundcube-9999.ebuild
+++ b/mail-client/roundcube/roundcube-9999.ebuild
@@ -24,7 +24,7 @@ need_httpd_cgi
RDEPEND="
${DEPEND}
- >=dev-lang/php-7.3.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]