summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-11-24 21:03:39 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2019-11-24 21:03:43 -0500
commit293bf0e6f17a2267b453cddcd6c8d6c7dbfd0ef6 (patch)
tree9ead64aa4900bdfc431a85c74e9f7925dca1c81e /mail-client
parentvirtual/wine: Remove reference to last rited package (diff)
downloadgentoo-293bf0e6f17a2267b453cddcd6c8d6c7dbfd0ef6.tar.gz
gentoo-293bf0e6f17a2267b453cddcd6c8d6c7dbfd0ef6.tar.bz2
gentoo-293bf0e6f17a2267b453cddcd6c8d6c7dbfd0ef6.zip
mail-client/roundcube: Bump to 1.4.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.4.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 3321c524c976..09042d04c265 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -2,3 +2,4 @@ DIST roundcubemail-1.3.10-complete.tar.gz 5495189 BLAKE2B d2b6d7ac28fc609ab3d727
DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57baa18d1f057fdd2eb0f872f3cef1053847861998f8c6551fc17506ae365086ed1f86c3ee9e73a96adb2e43c6c32025e7afaf63710 SHA512 34dc9205cd93be6d6551086f4d22654dad7213b4b09000dc4def08357acdc634744ce1f560144a3d3b46e936258e90482e77fc4c691a55c205bcfdfe3745441e
DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
DIST roundcubemail-1.4.0-complete.tar.gz 6997256 BLAKE2B b19a2d049512ceb53b3844f4680ed061044d2d142bef322c067b381e3be57ecb3181cac4f2492a162da1417fefb4028c36d34dae4bf9064c97568f681bd0c78b SHA512 274372793f1f3af761702f8972f6360f8c8e64a705ff96f1432f6a520d24c9ca0e8ccc3933f26433f1c864bd6c381066fc9eb48bf97e9497b4cbff855412d811
+DIST roundcubemail-1.4.1-complete.tar.gz 6998687 BLAKE2B ff33e512bb202d37d77ae2a4c7820f1061598bee1eb01bed5f15b25ad0e27c0cfe3611b44d451982491b702abcf6d7ae1bc88cbd303bc9a2573fc79efc54bec5 SHA512 0c8e09e93c86aad0f3e3a5a81c5e9ad8ab8aee101ae8ebb78d29556575db94a51a07cbf955ec79235425a961427b826ad27fae750b8eae785eedd195161dabed
diff --git a/mail-client/roundcube/roundcube-1.4.1.ebuild b/mail-client/roundcube/roundcube-1.4.1.ebuild
new file mode 100644
index 000000000000..e503aac30822
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.4.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}