summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-04-02 22:27:21 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-04-02 22:47:55 +0200
commit33a5145d1abab8b81e5b3545c04356beb1b5d6f6 (patch)
tree8efa5d9fde061cd7a1cecc05c1a13c9cd65446bf /mail-client
parentsys-apps/uutils-findutils: add 0.4.0 (diff)
downloadgentoo-33a5145d1abab8b81e5b3545c04356beb1b5d6f6.tar.gz
gentoo-33a5145d1abab8b81e5b3545c04356beb1b5d6f6.tar.bz2
gentoo-33a5145d1abab8b81e5b3545c04356beb1b5d6f6.zip
mail-client/claws-mail: migrate to net-libs/webkit-gtk:4.1
Closes: https://bugs.gentoo.org/893698 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild216
-rw-r--r--mail-client/claws-mail/files/claws-mail-4.1.1-webkitgtk4.1.patch317
2 files changed, 533 insertions, 0 deletions
diff --git a/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild b/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild
new file mode 100644
index 000000000000..7f85e4917eb5
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools desktop python-any-r1 xdg
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="https://www.claws-mail.org/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.claws-mail.org/readonly/claws.git"
+else
+ SRC_URI="https://www.claws-mail.org/download.php?file=releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+SLOT="0"
+QA_PKGCONFIG_VERSION="${PV}.0"
+LICENSE="GPL-3"
+
+IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls +imap ldap +libcanberra +libnotify litehtml networkmanager nls nntp +notification +oauth pdf perl +pgp rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind webkit xface"
+REQUIRED_USE="
+ libcanberra? ( notification )
+ libnotify? ( notification )
+ networkmanager? ( dbus )
+ oauth? ( gnutls )
+ smime? ( pgp )
+"
+
+COMMONDEPEND="
+ >=dev-libs/glib-2.36:2
+ dev-libs/nettle:=
+ net-mail/ytnef
+ sys-libs/zlib:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ archive? (
+ app-arch/libarchive
+ >=net-misc/curl-7.9.7
+ )
+ bogofilter? ( mail-filter/bogofilter )
+ calendar? (
+ dev-lang/perl:=
+ >=dev-libs/libical-2.0.0:=
+ >=net-misc/curl-7.9.7
+ )
+ dbus? (
+ >=dev-libs/dbus-glib-0.60
+ sys-apps/dbus
+ )
+ gdata? ( >=dev-libs/libgdata-0.17.2 )
+ dillo? ( www-client/dillo )
+ gnutls? ( >=net-libs/gnutls-3.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ ldap? ( >=net-nds/openldap-2.0.7:= )
+ litehtml? (
+ >=dev-libs/gumbo-0.10
+ net-misc/curl
+ media-libs/fontconfig
+ )
+ nls? ( >=sys-devel/gettext-0.18 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ notification? (
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ libnotify? ( x11-libs/libnotify )
+ )
+ perl? ( dev-lang/perl:= )
+ pdf? ( app-text/poppler[cairo] )
+ pgp? ( >=app-crypt/gpgme-1.0.0:= )
+ rss? (
+ dev-libs/libxml2
+ net-misc/curl
+ )
+ session? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ smime? ( >=app-crypt/gpgme-1.0.0:= )
+ spam-report? ( >=net-misc/curl-7.9.7 )
+ spell? ( >=app-text/enchant-2.0.0:2= )
+ startup-notification? ( x11-libs/startup-notification )
+ svg? ( >=gnome-base/librsvg-2.40.5 )
+ valgrind? ( dev-util/valgrind )
+ webkit? ( net-libs/webkit-gtk:4.1 )
+"
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info
+ clamav? ( app-antivirus/clamav )
+ networkmanager? ( net-misc/networkmanager )
+ pdf? ( app-text/ghostscript-gpl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.17.5-enchant-2_default.patch"
+ "${FILESDIR}/${PN}-4.1.1-fix_lto.patch"
+ "${FILESDIR}/${P}-webkitgtk4.1.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-bsfilter-plugin
+ --disable-generic-umpc
+ --disable-jpilot #735118
+ --disable-python-plugin
+ --enable-acpi_notifier-plugin
+ --enable-address_keeper-plugin
+ --enable-alternate-addressbook
+ --enable-att_remover-plugin
+ --enable-attachwarner-plugin
+ --enable-fetchinfo-plugin
+ --enable-ipv6
+ --enable-mailmbox-plugin
+ --enable-newmail-plugin
+ --enable-tnef_parse-plugin
+ --with-password-encryption=$(usex gnutls gnutls old)
+ $(use_enable archive archive-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable calendar vcalendar-plugin)
+ $(use_enable clamav clamd-plugin)
+ $(use_enable dbus)
+ $(use_enable debug crash-dialog)
+ $(use_enable dillo dillo-plugin)
+ $(use_enable doc manual)
+ $(use_enable gdata gdata-plugin)
+ $(use_enable gnutls)
+ $(use_enable ldap)
+ $(use_enable litehtml litehtml_viewer-plugin)
+ $(use_enable networkmanager)
+ $(use_enable nls)
+ $(use_enable notification notification-plugin)
+ $(use_enable oauth oauth2)
+ $(use_enable pdf pdf_viewer-plugin)
+ $(use_enable perl perl-plugin)
+ $(use_enable pgp pgpcore-plugin)
+ $(use_enable pgp pgpinline-plugin)
+ $(use_enable pgp pgpmime-plugin)
+ $(use_enable rss rssyl-plugin)
+ $(use_enable session libsm)
+ $(use_enable sieve managesieve-plugin)
+ $(use_enable smime smime-plugin)
+ $(use_enable spam-report spam_report-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable spell enchant)
+ $(use_enable startup-notification)
+ $(use_enable svg)
+ $(use_enable valgrind valgrind)
+ $(use_enable webkit fancy-plugin)
+ $(use_enable xface compface)
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp ; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ default
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png
+ local size
+ for size in 64 128 ; do
+ newicon -s ${size} ${PN}-${size}x${size}.png ${PN}.png
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools || die
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh
+ doexe tb2claws-mail update-po uudec uuooffice
+
+ # kill useless files
+ find "${ED}"/usr/$(get_libdir)/${PN}/plugins/ \
+ \( -name "*.a" -o -name "*.la" \) -delete || die
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from version 3.x please re-load any plugin you use"
+ xdg_pkg_postinst
+}
diff --git a/mail-client/claws-mail/files/claws-mail-4.1.1-webkitgtk4.1.patch b/mail-client/claws-mail/files/claws-mail-4.1.1-webkitgtk4.1.patch
new file mode 100644
index 000000000000..cfd9cb6842e8
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-4.1.1-webkitgtk4.1.patch
@@ -0,0 +1,317 @@
+diff -Naur claws-mail-4.1.1.orig/configure.ac claws-mail-4.1.1/configure.ac
+--- claws-mail-4.1.1.orig/configure.ac 2022-10-20 10:13:00.000000000 +0200
++++ claws-mail-4.1.1/configure.ac 2023-04-02 22:12:14.715133250 +0200
+@@ -1238,26 +1238,10 @@
+ AC_SUBST(EXPAT_LIBS)
+
+ dnl webkit *********************************************************************
+-PKG_CHECK_MODULES(WEBKIT, webkit2gtk-4.0 >= 2.18.0, HAVE_WEBKIT=yes, HAVE_WEBKIT=no)
++PKG_CHECK_MODULES(WEBKIT, webkit2gtk-4.1 >= 2.18.0, HAVE_WEBKIT=yes, HAVE_WEBKIT=no)
+ AC_SUBST(WEBKIT_LIBS)
+ AC_SUBST(WEBKIT_CFLAGS)
+
+-dnl libsoup ********************************************************************
+-PKG_CHECK_MODULES(LIBSOUP, libsoup-2.4, HAVE_LIBSOUP=yes, HAVE_LIBSOUP=no)
+-if test x"$HAVE_LIBSOUP" = xyes; then
+- AC_DEFINE(HAVE_LIBSOUP, 1, [Define if libsoup is available])
+-fi
+-AC_SUBST(LIBSOUP_CFLAGS)
+-AC_SUBST(LIBSOUP_LIBS)
+-
+-dnl libsoup-gnome **************************************************************
+-PKG_CHECK_MODULES(LIBSOUP_GNOME, libsoup-gnome-2.4 >= 2.26, HAVE_LIBSOUP_GNOME=yes, HAVE_LIBSOUP_GNOME=no)
+-if test x"$HAVE_LIBSOUP_GNOME" = xyes; then
+- AC_DEFINE(HAVE_LIBSOUP_GNOME, 1, [Define if libsoup_gnome is available])
+-fi
+-AC_SUBST(LIBSOUP_GNOME_CFLAGS)
+-AC_SUBST(LIBSOUP_GNOME_LIBS)
+-
+ dnl libarchive *****************************************************************
+ PKG_CHECK_MODULES(LIBARCHIVE, libarchive, HAVE_ARCHIVE=yes, HAVE_ARCHIVE=no)
+ AC_SUBST(ARCHIVE_LIBS)
+@@ -1573,7 +1557,7 @@
+ dependencies_missing=""
+
+ if test x"$HAVE_WEBKIT" = xno; then
+- dependencies_missing="libwebkit2gtk-4.0 $dependencies_missing"
++ dependencies_missing="libwebkit2gtk-4.1 $dependencies_missing"
+ fi
+ if test x"$HAVE_CURL" = xno; then
+ dependencies_missing="libcurl $dependencies_missing"
+diff -Naur claws-mail-4.1.1.orig/src/plugins/fancy/fancy_prefs.c claws-mail-4.1.1/src/plugins/fancy/fancy_prefs.c
+--- claws-mail-4.1.1.orig/src/plugins/fancy/fancy_prefs.c 2022-05-06 12:11:04.000000000 +0200
++++ claws-mail-4.1.1/src/plugins/fancy/fancy_prefs.c 2023-04-02 22:07:34.285867703 +0200
+@@ -46,11 +46,8 @@
+
+ FancyPrefs fancy_prefs;
+
+-static void prefs_set_proxy_entry_sens(GtkWidget *button, GtkEntry *entry_str);
++// static void prefs_set_proxy_entry_sens(GtkWidget *button, GtkEntry *entry_str);
+
+-#ifdef HAVE_LIBSOUP_GNOME
+-static void prefs_disable_fancy_proxy(GtkWidget *checkbox, GtkWidget *block);
+-#endif
+ typedef struct _FancyPrefsPage FancyPrefsPage;
+
+ struct _FancyPrefsPage {
+@@ -61,11 +58,8 @@
+ GtkWidget *enable_plugins;
+ GtkWidget *enable_java;
+ GtkWidget *open_external;
+-#ifdef HAVE_LIBSOUP_GNOME
+- GtkWidget *gnome_proxy_checkbox;
+-#endif
+- GtkWidget *proxy_checkbox;
+- GtkWidget *proxy_str;
++/* GtkWidget *proxy_checkbox;
++ GtkWidget *proxy_str; */
+ GtkWidget *stylesheet;
+ };
+
+@@ -84,14 +78,10 @@
+ NULL, NULL, NULL},
+ {"enable_java", "FALSE", &fancy_prefs.enable_java, P_BOOL,
+ NULL, NULL, NULL},
+-#ifdef HAVE_LIBSOUP_GNOME
+- {"enable_gnome_proxy","FALSE", &fancy_prefs.enable_gnome_proxy, P_BOOL,
+- NULL, NULL, NULL},
+-#endif
+- {"enable_proxy", "FALSE", &fancy_prefs.enable_proxy, P_BOOL,
++/* {"enable_proxy", "FALSE", &fancy_prefs.enable_proxy, P_BOOL,
+ NULL, NULL, NULL},
+ {"proxy_server", "http://SERVERNAME:PORT", &fancy_prefs.proxy_str, P_STRING,
+- NULL, NULL, NULL},
++ NULL, NULL, NULL}, */
+ {"stylesheet", "", &fancy_prefs.stylesheet, P_STRING, NULL, NULL, NULL},
+ {0,0,0,0,0,0,0}
+ };
+@@ -180,14 +170,11 @@
+ FancyPrefsPage *prefs_page = (FancyPrefsPage *) page;
+
+ GtkWidget *vbox;
+-#ifdef HAVE_LIBSOUP_GNOME
+- GtkWidget *gnome_proxy_checkbox;
+-#endif
+- GtkWidget *proxy_checkbox;
++/* GtkWidget *proxy_checkbox;
+ GtkWidget *proxy_str;
+ GtkWidget *vbox_proxy;
+ GtkWidget *frame_proxy;
+-
++*/
+ GtkWidget *frame_remote;
+ GtkWidget *vbox_remote;
+ GtkWidget *remote_label;
+@@ -204,25 +191,12 @@
+ vbox = gtk_box_new(GTK_ORIENTATION_VERTICAL, 3);
+ gtk_container_set_border_width(GTK_CONTAINER(vbox), VBOX_BORDER);
+ gtk_widget_show(vbox);
+-
++/*
+ GtkWidget *block = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, 5);
+
+ vbox_proxy = gtkut_get_options_frame(vbox, &frame_proxy, _("Proxy"));
+-#ifdef HAVE_LIBSOUP_GNOME
+- gnome_proxy_checkbox = gtk_check_button_new_with_label(_("Use GNOME's proxy settings"));
+- gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(gnome_proxy_checkbox),
+- fancy_prefs.enable_gnome_proxy);
+- gtk_box_pack_start(GTK_BOX(vbox_proxy), gnome_proxy_checkbox, FALSE, FALSE, 0);
+- gtk_widget_show(gnome_proxy_checkbox);
+- g_signal_connect(G_OBJECT(gnome_proxy_checkbox), "toggled",
+- G_CALLBACK(prefs_disable_fancy_proxy), block);
+-#endif
+ proxy_checkbox = gtk_check_button_new_with_label(_("Use proxy"));
+ proxy_str = gtk_entry_new();
+-#ifdef HAVE_LIBSOUP_GNOME
+- if (fancy_prefs.enable_gnome_proxy)
+- gtk_widget_set_sensitive(proxy_checkbox, FALSE);
+-#endif
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(proxy_checkbox),
+ fancy_prefs.enable_proxy);
+ prefs_set_proxy_entry_sens(proxy_checkbox, GTK_ENTRY(proxy_str));
+@@ -234,7 +208,7 @@
+ gtk_box_pack_start(GTK_BOX(block), proxy_str, TRUE, TRUE, 0);
+ gtk_box_pack_start(GTK_BOX(vbox_proxy), block, FALSE, FALSE, 0);
+ gtk_widget_show_all(vbox_proxy);
+-
++*/
+ vbox_remote = gtkut_get_options_frame(vbox, &frame_remote, _("Remote resources"));
+ remote_label = gtk_label_new(_("Loading remote resources can lead to some privacy issues.\n"
+ "When remote content loading is disabled, nothing will be requested\n"
+@@ -323,12 +297,8 @@
+ pref_set_entry_from_pref(GTK_ENTRY(stylesheet), fancy_prefs.stylesheet);
+ g_signal_emit_by_name(G_OBJECT(stylesheet), "changed", stylesheet_edit_button);
+
+-
+-#ifdef HAVE_LIBSOUP_GNOME
+- prefs_page->gnome_proxy_checkbox = gnome_proxy_checkbox;
+-#endif
+- prefs_page->proxy_checkbox = proxy_checkbox;
+- prefs_page->proxy_str = proxy_str;
++/* prefs_page->proxy_checkbox = proxy_checkbox;
++ prefs_page->proxy_str = proxy_str; */
+ prefs_page->enable_remote_content = enable_remote_content;
+ prefs_page->enable_images = enable_images;
+ prefs_page->enable_scripts = enable_scripts;
+@@ -374,25 +344,12 @@
+ const gchar *stylesheet = gtk_entry_get_text(GTK_ENTRY(widget));
+ gtk_widget_set_sensitive(GTK_WIDGET(data), (*stylesheet)? TRUE: FALSE);
+ }
+-
++/*
+ static void prefs_set_proxy_entry_sens(GtkWidget *button, GtkEntry *entry_str) {
+ gtk_widget_set_sensitive(GTK_WIDGET(entry_str),
+ gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(button)));
+ }
+-
+-#ifdef HAVE_LIBSOUP_GNOME
+-static void prefs_disable_fancy_proxy(GtkWidget *checkbox, GtkWidget *block) {
+- gboolean toggle = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(checkbox));
+- gtk_widget_set_sensitive(block, !toggle);
+- GList *list = g_list_first(gtk_container_get_children(GTK_CONTAINER(block)));
+- if (toggle) {
+- gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(list->data), FALSE);
+- }
+- else {
+- gtk_widget_set_sensitive(GTK_WIDGET(list->data), TRUE);
+- }
+-}
+-#endif
++*/
+ static void destroy_fancy_prefs_page(PrefsPage *page)
+ {
+ /* Do nothing! */
+@@ -425,10 +382,6 @@
+ {
+ FancyPrefsPage *prefs_page = (FancyPrefsPage *) page;
+
+-#ifdef HAVE_LIBSOUP_GNOME
+- fancy_prefs.enable_gnome_proxy = gtk_toggle_button_get_active
+- (GTK_TOGGLE_BUTTON(prefs_page->gnome_proxy_checkbox));
+-#endif
+ fancy_prefs.enable_images = gtk_toggle_button_get_active
+ (GTK_TOGGLE_BUTTON(prefs_page->enable_images));
+ fancy_prefs.enable_remote_content = gtk_toggle_button_get_active
+@@ -441,9 +394,9 @@
+ (GTK_TOGGLE_BUTTON(prefs_page->enable_java));
+ fancy_prefs.open_external = combobox_get_active_data
+ (GTK_COMBO_BOX(prefs_page->open_external));
+- fancy_prefs.enable_proxy = gtk_toggle_button_get_active
++/* fancy_prefs.enable_proxy = gtk_toggle_button_get_active
+ (GTK_TOGGLE_BUTTON(prefs_page->proxy_checkbox));
+- fancy_prefs.proxy_str = pref_get_pref_from_entry(GTK_ENTRY(prefs_page->proxy_str));
++ fancy_prefs.proxy_str = pref_get_pref_from_entry(GTK_ENTRY(prefs_page->proxy_str)); */
+ #ifdef G_OS_WIN32
+ /* pref_get_pref_from_entry() escapes the backslashes in strings,
+ * we do not want that, since this entry contains a Windows path.
+diff -Naur claws-mail-4.1.1.orig/src/plugins/fancy/fancy_prefs.h claws-mail-4.1.1/src/plugins/fancy/fancy_prefs.h
+--- claws-mail-4.1.1.orig/src/plugins/fancy/fancy_prefs.h 2022-05-06 12:11:04.000000000 +0200
++++ claws-mail-4.1.1/src/plugins/fancy/fancy_prefs.h 2023-04-02 22:07:34.285867703 +0200
+@@ -1,6 +1,6 @@
+ /*
+ * Claws Mail -- A GTK based, lightweight, and fast e-mail client
+- * Copyright(C) 1999-2014 the Claws Mail Team
++ * Copyright(C) 1999-2023 the Claws Mail Team
+ * == Fancy Plugin ==
+ * This file Copyright (C) 2009 -2014 Salvatore De Paolis
+ * <iwkse@claws-mail.org> and the Claws Mail Team
+@@ -35,11 +35,8 @@
+ gboolean enable_java;
+ gboolean open_external;
+ gint zoom_level;
+-#ifdef HAVE_LIBSOUP_GNOME
+- gboolean enable_gnome_proxy;
+-#endif
+- gboolean enable_proxy;
+- gchar *proxy_str;
++ // gboolean enable_proxy;
++ // gchar *proxy_str;
+ gchar *stylesheet;
+ };
+
+diff -Naur claws-mail-4.1.1.orig/src/plugins/fancy/fancy_viewer.c claws-mail-4.1.1/src/plugins/fancy/fancy_viewer.c
+--- claws-mail-4.1.1.orig/src/plugins/fancy/fancy_viewer.c 2022-10-20 09:16:02.000000000 +0200
++++ claws-mail-4.1.1/src/plugins/fancy/fancy_viewer.c 2023-04-02 22:07:34.285867703 +0200
+@@ -1,7 +1,7 @@
+ /*
+ * Claws Mail -- A GTK based, lightweight, and fast e-mail client
+ * == Fancy Plugin ==
+- * Copyright(C) 1999-2022 the Claws Mail Team
++ * Copyright(C) 1999-2023 the Claws Mail Team
+ * This file Copyright (C) 2009-2014 Salvatore De Paolis
+ * <iwkse@claws-mail.org> and the Claws Mail Team
+ *
+@@ -1106,23 +1106,6 @@
+ viewer->mimeviewer.scroll_one_line = fancy_scroll_one_line;
+ viewer->view = WEBKIT_WEB_VIEW(webkit_web_view_new());
+
+-/*#ifdef HAVE_LIBSOUP_GNOME
+- TODO webkit_get_default_session() missing
+- * enum WebKitNetworkProxySettings
+- * */
+- /* Use GNOME proxy settings through libproxy */
+-/* if (fancy_prefs.enable_gnome_proxy) {
+- SoupSession *session = webkit_get_default_session();
+- soup_session_add_feature_by_type (session, SOUP_TYPE_PROXY_RESOLVER_GNOME);
+- }
+-#endif
+-
+- if (fancy_prefs.enable_proxy) {
+- SoupSession *session = webkit_get_default_session();
+- SoupURI* pURI = soup_uri_new(fancy_prefs.proxy_str);
+- g_object_set(session, "proxy-uri", pURI, NULL);
+- }
+-*/
+ viewer->settings = webkit_settings_new();
+ g_object_set(viewer->settings, "user-agent", "Fancy Viewer", NULL);
+ viewer->scrollwin = gtk_scrolled_window_new(NULL, NULL);
+diff -Naur claws-mail-4.1.1.orig/src/plugins/fancy/fancy_viewer.h claws-mail-4.1.1/src/plugins/fancy/fancy_viewer.h
+--- claws-mail-4.1.1.orig/src/plugins/fancy/fancy_viewer.h 2022-10-19 16:49:50.000000000 +0200
++++ claws-mail-4.1.1/src/plugins/fancy/fancy_viewer.h 2023-04-02 22:07:34.285867703 +0200
+@@ -1,8 +1,8 @@
+ /*
+ * Claws Mail -- a GTK based, lightweight, and fast e-mail client
+ * == Fancy Plugin ==
+- * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail Team
+- * This file Copyright (C) 2009-2013 Salvatore De Paolis <iwkse@claws-mail.org>
++ * Copyright (C) 1999-2023 the Claws Mail Team
++ * This file Copyright (C) 2009-2023 Salvatore De Paolis <iwkse@claws-mail.org>
+ * and the Claws Mail Team
+ *
+ * This program is free software; you can redistribute it and/or modify
+@@ -51,10 +51,6 @@
+ #include <curl/curlver.h>
+ #include "filesel.h"
+
+-#ifdef HAVE_LIBSOUP_GNOME
+-#include <libsoup/soup-gnome.h>
+-#endif
+-
+ typedef enum _NavigationMode {
+ NAV_DEFAULT,
+ NAV_INNER,
+diff -Naur claws-mail-4.1.1.orig/src/plugins/fancy/Makefile.am claws-mail-4.1.1/src/plugins/fancy/Makefile.am
+--- claws-mail-4.1.1.orig/src/plugins/fancy/Makefile.am 2022-10-20 09:16:02.000000000 +0200
++++ claws-mail-4.1.1/src/plugins/fancy/Makefile.am 2023-04-02 22:07:34.285867703 +0200
+@@ -1,4 +1,4 @@
+-# Copyright 1999-2022 the Claws Mail team.
++# Copyright 1999-2023 the Claws Mail team.
+ # This file is part of Claws Mail package, and distributed under the
+ # terms of the General Public License version 3 (or later).
+ # See COPYING file for license details.
+@@ -28,7 +28,6 @@
+ fancy_la_LIBADD = $(plugin_libadd) \
+ $(GTK_LIBS) \
+ $(WEBKIT_LIBS) \
+- $(LIBSOUP_GNOME_LIBS) \
+ $(CURL_LIBS)
+
+ fancy_la_CPPFLAGS = \
+@@ -37,7 +36,6 @@
+ $(GTK_CFLAGS) \
+ $(ENCHANT_CFLAGS) \
+ $(WEBKIT_CFLAGS) \
+- $(LIBSOUP_GNOME_CFLAGS) \
+ $(CURL_CFLAGS) \
+ -DFANCY_WEB_EXTENSIONS_DIR=\""$(pkglibdir)/plugins/web_extensions"\" \
+ -DFANCY_WEB_EXTENSION_FILE=\""fancywebextension"\"