summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-08-01 13:26:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-14 11:20:41 +0300
commit5c832d4085dc5db68e5bf11f0d169e1e8dbdd51e (patch)
treeb952711083ddf212c300594e81783cce493a23c3 /mail-client
parentsys-fs/btrfsmaintenance: version bump to 0.5 (diff)
downloadgentoo-5c832d4085dc5db68e5bf11f0d169e1e8dbdd51e.tar.gz
gentoo-5c832d4085dc5db68e5bf11f0d169e1e8dbdd51e.tar.bz2
gentoo-5c832d4085dc5db68e5bf11f0d169e1e8dbdd51e.zip
mail-client/bower: Bump to version 0.12
The ebuild causes QA notices. I filed an upstream ticket[1] for this reason in 2018, which is still open today. The author of Bower suggests "just ignoring the warning for now as it's not a real problem." [1] https://github.com/wangp/bower/issues/36 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/16928 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/bower/Manifest1
-rw-r--r--mail-client/bower/bower-0.12.ebuild39
-rw-r--r--mail-client/bower/metadata.xml3
3 files changed, 42 insertions, 1 deletions
diff --git a/mail-client/bower/Manifest b/mail-client/bower/Manifest
index 59b85ed32f58..38647786fbcb 100644
--- a/mail-client/bower/Manifest
+++ b/mail-client/bower/Manifest
@@ -1,2 +1,3 @@
DIST bower-0.10.tar.gz 261487 BLAKE2B 861ee1e17787586f12795fb507cb32fd2d63b8831083354aed9f710c06cc8714ede7421d64c7aa6f2a52aec954be89fe15f1a4a2292d044c9b6a754c754d9667 SHA512 54ba7492008f1f6f1495b0d8a7585965ecf6ba16701bd19234dc761190db701d7cdc9a4e0e5995846f2feb08018a217a0e405dea0dacb3fbfb5681ed66529b9a
DIST bower-0.11.tar.gz 266063 BLAKE2B 04fbf8febf472f39a6b2a39e5ea36311fa9b2fd931264315053bccd655ba94ea0c163c54cdf80c1d614df91b77c04543e8fdc34ff8cd42f2795dabae91cde95c SHA512 67d803a393b72e7140c1f252d86c693d31c2e570506aa22e64c6417a0bc51d14f7b6f4bdb89d5098dd32bcf0ac82b1a7b1a801325c856e9f6c58750d2cfa20e8
+DIST bower-0.12.tar.gz 275436 BLAKE2B 66ea4d0a502f9948bd7af29c6d63bd7c0c382d91a875dbcea4db8a55f457202cb70351fee151a7bc03a7ba1b0a2877cb4db76b0f6b8c38bf30c6072e3a74c9b7 SHA512 efa0ced9ddc13b2df43874acfa90843eef46ae527e2796d1368c234b7cc8c7c0a9b173398a0180b0eee52d94ba339f2b3bc65a91d07a563c320dbc86ae1521c3
diff --git a/mail-client/bower/bower-0.12.ebuild b/mail-client/bower/bower-0.12.ebuild
new file mode 100644
index 000000000000..d76953ce7610
--- /dev/null
+++ b/mail-client/bower/bower-0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="Curses terminal client for the Notmuch email system"
+HOMEPAGE="https://github.com/wangp/bower"
+SRC_URI="https://github.com/wangp/bower/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="app-crypt/gpgme:=
+ sys-libs/ncurses:0="
+DEPEND="${COMMON_DEPEND}
+ dev-lang/mercury"
+RDEPEND="${COMMON_DEPEND}
+ net-mail/notmuch
+ sys-apps/coreutils"
+
+src_prepare() {
+ default
+ if has_version "sys-libs/ncurses:0[tinfo]" ; then
+ echo "MLLIBS-bower += -ltinfow" >> src/Mercury.params || die
+ fi
+}
+
+src_compile() {
+ emake PARALLEL="--jobs $(makeopts_jobs) --no-strip --very-verbose"
+}
+
+src_install() {
+ dobin bower
+ dodoc AUTHORS NEWS README.md bower.conf.sample
+}
diff --git a/mail-client/bower/metadata.xml b/mail-client/bower/metadata.xml
index 5560cae3b5ec..0d11f2881462 100644
--- a/mail-client/bower/metadata.xml
+++ b/mail-client/bower/metadata.xml
@@ -10,7 +10,8 @@
<name>Proxy Maintainers</name>
</maintainer>
<longdescription>
- Bower is a curses frontend for the Notmuch email system, written in Mercury.
+ Bower is a curses frontend for the Notmuch (https://notmuchmail.org)
+ email system, written in Mercury.
</longdescription>
<upstream>
<remote-id type="github">wangp/bower</remote-id>