summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-11 22:33:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-11 22:35:06 +0900
commit8655bf0b1f2df0d02e85abfaee53a431ac1a72bd (patch)
tree4011e6b96e5a6ffa617a9c556f86c52f1aaf2294 /mail-client
parentmail-client/sylpheed: use xdg eclass (diff)
downloadgentoo-8655bf0b1f2df0d02e85abfaee53a431ac1a72bd.tar.gz
gentoo-8655bf0b1f2df0d02e85abfaee53a431ac1a72bd.tar.bz2
gentoo-8655bf0b1f2df0d02e85abfaee53a431ac1a72bd.zip
mail-client/sylpheed: enable SNI for TLS 1.3
Closes: https://bugs.gentoo.org/697460 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/files/sylpheed-tls-1.3.patch17
-rw-r--r--mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/mail-client/sylpheed/files/sylpheed-tls-1.3.patch b/mail-client/sylpheed/files/sylpheed-tls-1.3.patch
new file mode 100644
index 000000000000..a8215dd2a0d1
--- /dev/null
+++ b/mail-client/sylpheed/files/sylpheed-tls-1.3.patch
@@ -0,0 +1,17 @@
+https://sylpheed.sraoss.jp/redmine/issues/306
+
+Author: Antonio Ospite <ao2@ao2.it>
+
+--- a/libsylph/ssl.c
++++ b/libsylph/ssl.c
+@@ -262,6 +262,10 @@ gboolean ssl_init_socket_with_method(SockInfo *sockinfo, SSLMethod method)
+ return FALSE;
+ }
+
++#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++ SSL_set_tlsext_host_name(sockinfo->ssl, sockinfo->hostname);
++#endif
++
+ SSL_set_fd(sockinfo->ssl, sockinfo->sock);
+ while ((ret = SSL_connect(sockinfo->ssl)) != 1) {
+ err = SSL_get_error(sockinfo->ssl, ret);
diff --git a/mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild b/mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild
index aa5835e622df..86628b8d25bf 100644
--- a/mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild
+++ b/mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild
@@ -35,6 +35,7 @@ DEPEND="${CDEPEND}
xface? ( media-libs/compface )"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${PN}-tls-1.3.patch )
DOCS="AUTHORS ChangeLog* NEW* PLUGIN* README* TODO*"
src_configure() {