summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-24 10:43:40 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-24 10:48:01 +0300
commit98480bf85d035209c098e69731307bd614321358 (patch)
tree2f8fea9aad7b62e2b2b3e9f1f8044e03b477b5b5 /mail-client
parentdev-haskell/process-extras: drop old (diff)
downloadgentoo-98480bf85d035209c098e69731307bd614321358.tar.gz
gentoo-98480bf85d035209c098e69731307bd614321358.tar.bz2
gentoo-98480bf85d035209c098e69731307bd614321358.zip
mail-client/balsa: bump to 2.6.1
Bug: https://bugs.gentoo.org/725910 Closes: https://bugs.gentoo.org/698670 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/balsa/Manifest1
-rw-r--r--mail-client/balsa/balsa-2.6.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/mail-client/balsa/Manifest b/mail-client/balsa/Manifest
index b4aad9b7f2f8..66b4d991a68e 100644
--- a/mail-client/balsa/Manifest
+++ b/mail-client/balsa/Manifest
@@ -1 +1,2 @@
DIST balsa-2.5.6.tar.bz2 4468877 BLAKE2B 1e7f678c69121fe3472bbba8dc3d2a62680e1969934580a8a85725e84676531f1efb8432380c2d537ca584001c5cecd5c76cd033a1c1e68a292fc765bbc15f8d SHA512 a9c8094ac48b9b1a0971fe45a4658b728f93ad170ad7884c9554420a4696a7b6f5b3661bde8ab070f6a5c14a80f67551745e1d40905881429ae1d8e5874e9a68
+DIST balsa-2.6.1.tar.bz2 4535550 BLAKE2B eee4530fe9bdd0f9453178fb7a9e64584193221754dd8fc75703ec5f98214999a9d323357b415ead2fc218461adb4d0d082389f236c6f864b54a90790c889130 SHA512 242c93e698390647b93f7e163b547b326675a0600ff5c50c2db3f3e08cd045e32cec4bb69f8a44ef3443d4cf03cb194ac7971d2a0e55f7c84b273a2b627e2433
diff --git a/mail-client/balsa/balsa-2.6.1.ebuild b/mail-client/balsa/balsa-2.6.1.ebuild
new file mode 100644
index 000000000000..c3a17aeb0e7f
--- /dev/null
+++ b/mail-client/balsa/balsa-2.6.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
+SRC_URI="http://pawsa.fedorapeople.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="gnome +gnome-keyring kerberos ldap libressl rubrica sqlite webkit xface"
+
+# TODO: internal spell checking via enchant-2 instead of gtkspell/gspell?
+RDEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=x11-libs/gtk+-3.18.0:3
+ >=dev-libs/gmime-3.2.6:3.0
+ >=net-libs/gnutls-3.0:=
+ dev-libs/fribidi
+ dev-libs/libical:=
+ webkit? (
+ net-libs/webkit-gtk:4
+ app-text/html2text
+ )
+ >=app-crypt/gpgme-1.5.0:=
+ sqlite? ( >=dev-db/sqlite-2.8:= )
+ ldap? ( net-nds/openldap )
+ rubrica? ( dev-libs/libxml2:2 )
+ kerberos? ( app-crypt/mit-krb5 )
+ xface? ( >=media-libs/compface-1.5.1:= )
+ gnome? ( x11-libs/gtksourceview:4 )
+ media-libs/libcanberra:=[gtk3]
+ gnome-keyring? ( app-crypt/libsecret )
+ >=app-text/gspell-1.2:0=
+
+ net-mail/mailbase
+ x11-themes/hicolor-icon-theme
+ x11-themes/adwaita-icon-theme
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-update-icon-cache
+ dev-util/intltool
+ dev-util/itstool
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-libs/libxml2:2
+"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+src_configure() {
+ local myconf=(
+ $(use_with gnome)
+ $(use_enable sqlite autocrypt)
+ --with-canberra
+ $(use_with xface compface)
+ $(use_with kerberos gss)
+ $(usex webkit --with-html-widget=webkit2 --with-html-widget=no)
+ $(use_with gnome gtksourceview)
+ --with-spell-checker=gspell
+ $(use_with ldap)
+ $(use_with rubrica)
+ --without-osmo
+ $(use_with sqlite)
+ $(use_with gnome-keyring libsecret)
+ --without-gcr # experimental
+ )
+ gnome2_src_configure "${myconf[@]}"
+}