summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-08-11 18:40:13 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-08-21 10:14:45 +0300
commita5ebc9e221f29a92ece0eef16daab03e3be233ac (patch)
treebad1b269f9e586c415cdfc3ca822781ebfe3b5f9 /mail-client
parentsys-apps/hd-idle: Drop old. (diff)
downloadgentoo-a5ebc9e221f29a92ece0eef16daab03e3be233ac.tar.gz
gentoo-a5ebc9e221f29a92ece0eef16daab03e3be233ac.tar.bz2
gentoo-a5ebc9e221f29a92ece0eef16daab03e3be233ac.zip
mail-client/mutt-wizard: bump dated version
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt-wizard/Manifest1
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-0_pre20200808.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/Manifest b/mail-client/mutt-wizard/Manifest
index 2fe037de0813..3ef08774cafe 100644
--- a/mail-client/mutt-wizard/Manifest
+++ b/mail-client/mutt-wizard/Manifest
@@ -1 +1,2 @@
DIST mutt-wizard-0_pre20200606.tar.gz 32391 BLAKE2B 2ea165c8a94ebb7a7e28ff466c93f87a0a9f89de98ad71039ea610b6120c1c89922a39ee505159e4139d9a6d29b727ae706a2ec57378b838774a7564afe54e74 SHA512 008688a7d7ad8d895334900a0a060a7c3724519a4a49120d50e9cb0b1cad6e3c63fd7f16985333e35fb46b1bdaae3934750fbc52370dc36927f9bc8482fb5363
+DIST mutt-wizard-0_pre20200808.tar.gz 30797 BLAKE2B 90b7382b6d2a687fa2ce5b267a00ee582c1ea89169185eb556f7e3aab4bbc822068fd691fbdaa843df0c525ec737a34acb39bc8a09d3c608837487825e57344b SHA512 e49de65658d4222d8932b1dd117631fffcd08493dc6e20a5157f8a3e336e179bf754ef64387f2b538c70898183a0413c99425a2751debb4b8d7cea5465076f57
diff --git a/mail-client/mutt-wizard/mutt-wizard-0_pre20200808.ebuild b/mail-client/mutt-wizard/mutt-wizard-0_pre20200808.ebuild
new file mode 100644
index 000000000000..49dfef7ec510
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-0_pre20200808.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ COMMIT=1492a11b3ee0a1c3f5544a351089ff154521b68b
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}