summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-04 22:08:22 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-04 22:09:20 -0800
commitc502ba7ee66f140b7878f241da84d379e76cef23 (patch)
tree8bbf3b8edacdaddd28e801ad280d0a90c8e0d43a /mail-client
parentdev-java/openjdk: unkeyword :8 on arm64 (diff)
downloadgentoo-c502ba7ee66f140b7878f241da84d379e76cef23.tar.gz
gentoo-c502ba7ee66f140b7878f241da84d379e76cef23.tar.bz2
gentoo-c502ba7ee66f140b7878f241da84d379e76cef23.zip
mail-client/aerc: add live ebuild
notmuch support not much tested, open bugs if you encounter issues! Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/aerc/aerc-9999.ebuild52
-rw-r--r--mail-client/aerc/metadata.xml3
2 files changed, 55 insertions, 0 deletions
diff --git a/mail-client/aerc/aerc-9999.ebuild b/mail-client/aerc/aerc-9999.ebuild
new file mode 100644
index 000000000000..455ac923f0d7
--- /dev/null
+++ b/mail-client/aerc/aerc-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 go-module
+
+DESCRIPTION="Email client for your terminal"
+HOMEPAGE="https://aerc-mail.org"
+
+EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/aerc"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+IUSE="notmuch"
+
+BDEPEND=">=app-text/scdoc-1.9.7"
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+}
+
+src_compile() {
+ use notmuch && export GOFLAGS="-tags=notmuch"
+ emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you want to allow your users to activate html email"
+ elog "processing via w3m as shown in the tutorial, make sure you"
+ elog "emerge net-proxy/dante and www-client/w3m"
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test $v -lt 0.3.0-r1; then
+ elog "The dependencies on net-proxy/dante and www-client/w3m"
+ elog "have been removed since they are optional."
+ elog "Please emerge them before the next --depclean if you"
+ elog "need to use them."
+ fi
+ done
+}
diff --git a/mail-client/aerc/metadata.xml b/mail-client/aerc/metadata.xml
index e0d10bf223c0..b9e1b88aa68b 100644
--- a/mail-client/aerc/metadata.xml
+++ b/mail-client/aerc/metadata.xml
@@ -5,6 +5,9 @@
<email>gyakovlev@gentoo.org</email>
<name>Georgy Yakovlev</name>
</maintainer>
+ <use>
+ <flag name="notmuch">Enable support for <pkg>net-mail/notmuch</pkg></flag>
+ </use>
<longdescription lang="en">
Terminal email client with Vim-style keybindings, git awareness and other advanced features.
</longdescription>