summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2016-02-13 13:10:55 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2016-02-13 13:12:08 -0500
commitcdac53b1c4465d5884d1ae1d4280ccd134f02cd4 (patch)
tree3866850b020c1dd566946d3fd1121620c5ce2eaa /mail-client
parentmedia-sound/sndfile-tools: Prevent configure adding -Werror to CFLAGS (diff)
downloadgentoo-cdac53b1c4465d5884d1ae1d4280ccd134f02cd4.tar.gz
gentoo-cdac53b1c4465d5884d1ae1d4280ccd134f02cd4.tar.bz2
gentoo-cdac53b1c4465d5884d1ae1d4280ccd134f02cd4.zip
mail-client/roundcube: Version Bump
First version that can run under PHP7. Revised POST-UPGRADE text to include a couple additional steps that may be necessary. Bug: 574136 Package-Manager: portage-2.2.26
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/files/POST-UPGRADE.txt16
-rw-r--r--mail-client/roundcube/roundcube-1.2_beta.ebuild76
3 files changed, 88 insertions, 5 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 75eb7a0adafa..894f804cd78f 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1 +1,2 @@
DIST roundcubemail-1.1.4.tar.gz 3209549 SHA256 539a11ed38838b221f8139b193d9762638f155c7b0ea9391315865896be16852 SHA512 18c2422d65292cd13bc4ce592e8490cc0a9d3e9551ac4d188db93eb989525af7ccf519642dd2e68a7380ab0d0d4ad4f999af2b7e99da75d88274743949b42f8a WHIRLPOOL c3e310ddb4dc50b46ff28566d030865029364f69db5a3f39be0d37f165c83486a979b4d3ab7d42835baa7ea9506df8947381612403355a628864ecbde1238d02
+DIST roundcubemail-1.2-beta.tar.gz 3421215 SHA256 b7ab853c0a6e52641c851624c4405ce49643553b76c1f50b02b413cb7954fb25 SHA512 454083d6377a07bd418de5593cafb2cc7c0af474e178e322d07adeaa3473ce140a57e6d0a0ee3f58862091bc559596c98d4fb523ef6b9cee91d38064233aade6 WHIRLPOOL 059cd348397a31a3ebf2a6f58acbf832b0722b2740496ae32b4ef036a963a8199fd4f6e718895512ce1fc996da3af65c583f65faef8b817ba94d99fdfda896d3
diff --git a/mail-client/roundcube/files/POST-UPGRADE.txt b/mail-client/roundcube/files/POST-UPGRADE.txt
index 8c2296bc0a50..82b48d70f260 100644
--- a/mail-client/roundcube/files/POST-UPGRADE.txt
+++ b/mail-client/roundcube/files/POST-UPGRADE.txt
@@ -1,12 +1,18 @@
Post-Upgrade Activities
-----------------------
1. Check .htaccess settings (some php settings could become required)
-2. If you're using build-in addressbook, run indexing script
- /bin/indexcontacts.sh.
-3. When upgrading from version older than 0.6-beta you should make sure
- your folder settings contain namespace prefix. For example Courier users
- should add INBOX. prefix to folder names in main configuration file.
+2. If you're using the built-in addressbook, run indexing script:
+ ./bin/indexcontacts.sh.
+3. When upgrading from version older than 0.6-beta you should make sure your
+ folder settings contain a namespace prefix if necessary. For example Courier
+ users should add “INBOX.” prefix to folder names in main configuration file.
4. Check system requirements in INSTALL file.
+5. If you previously installed plugins through composer, update dependencies by
+ running:
+ php composer.phar self-update
+ php composer.phar update --no-dev
+6. Update your database and configurations by running:
+ ./bin/update.sh
SQLite database upgrade
-----------------------
diff --git a/mail-client/roundcube/roundcube-1.2_beta.ebuild b/mail-client/roundcube/roundcube-1.2_beta.ebuild
new file mode 100644
index 000000000000..1ebd091ec91d
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.2_beta.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS=""
+
+IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.0.6
+ >=dev-php/PEAR-Mail_Mime-1.8.9
+ >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Net_SMTP-1.6.2
+ virtual/httpd-php
+ enigma? ( >=dev-php/PEAR-Crypt_GPG-1.2.0 app-crypt/gnupg )
+ ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 )
+ managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+ fperms -R 0755 "${MY_HTDOCSDIR}"/bin
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if has_version "<mail-client/roundcube-1.0.0"; then
+ ewarn "When upgrading from <= 1.0.0, note that the old configuration files"
+ ewarn "named main.inc.php and db.inc.php are deprecated and should be"
+ ewarn "replaced with one single config.inc.php file."
+ ewarn
+ ewarn "Run the ./bin/update.sh script to convert those or manually merge the"
+ ewarn "files."
+ ewarn
+ ewarn "The new config.inc.php should only contain options that differ from"
+ ewarn "the ones listed in defaults.inc.php."
+ fi
+}