summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-27 20:00:27 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-27 21:03:38 +0100
commitedefeb811f7d48eea99b935d7ea2c9dcdb87ea71 (patch)
treedae1a1eff6124dcc5dee7d05f74af10a819d1f51 /mail-client
parentnet-misc/capi4hylafax: Use net-libs/libcapi (#595674) (diff)
downloadgentoo-edefeb811f7d48eea99b935d7ea2c9dcdb87ea71.tar.gz
gentoo-edefeb811f7d48eea99b935d7ea2c9dcdb87ea71.tar.bz2
gentoo-edefeb811f7d48eea99b935d7ea2c9dcdb87ea71.zip
mail-client/alpine: Disable topal support per bug #596532
Package-Manager: portage-2.3.2
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/alpine-2.00-r7.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/mail-client/alpine/alpine-2.00-r7.ebuild b/mail-client/alpine/alpine-2.00-r7.ebuild
new file mode 100644
index 000000000000..1b3beda5df3d
--- /dev/null
+++ b/mail-client/alpine/alpine-2.00-r7.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic autotools multilib toolchain-funcs
+
+CHAPPA_PL=115
+DESCRIPTION="alpine is an easy to use text-based based mail and news client"
+HOMEPAGE="http://www.washington.edu/alpine/ http://patches.freeiz.com/alpine/"
+SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
+ chappa? ( http://patches.freeiz.com/alpine/patches/alpine-2.00/all.patch.gz
+ -> ${P}-chappa-${CHAPPA_PL}-all.patch.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads +chappa"
+
+DEPEND="virtual/pam
+ >=net-libs/c-client-2007f-r4[chappa=]
+ >=sys-libs/ncurses-5.1:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ !onlyalpine? ( !mail-client/pine )
+ !<=net-mail/uw-imap-2004g
+"
+
+src_prepare() {
+ default
+ use chappa && epatch "${DISTDIR}/${P}-chappa-${CHAPPA_PL}-all.patch.gz"
+
+ # do not use the bundled c-client
+ ebegin "Unbundling the c-client library"
+ rm -rf "${S}"/imap
+ local f
+ while read f ; do
+ sed -i -e \
+ 's~^#include[[:blank:]]".*/c-client/\(.*\)"~#include <imap/\1>~g' "$f"
+ done < <(find "${S}" -name "*.c" -o -name "*.h")
+ eend $?
+
+ epatch "${FILESDIR}"/2.00-lpam.patch
+ epatch "${FILESDIR}"/2.00-lcrypto.patch
+ epatch "${FILESDIR}"/2.00-c-client.patch
+ epatch "${FILESDIR}"/2.00-qa.patch
+ use chappa && epatch "${FILESDIR}/2.00-qa-chappa-${CHAPPA_PL}.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--without-tcl
+ --with-system-pinerc=/etc/pine.conf
+ --with-system-fixed-pinerc=/etc/pine.conf.fixed"
+ #--disable-debug"
+ # fixme
+ # --with-system-mail-directory=DIR?
+
+ if use ssl; then
+ myconf+=" --with-ssl
+ --with-ssl-include-dir=/usr
+ --with-ssl-lib-dir=/usr/$(get_libdir)
+ --with-ssl-certs-dir=/etc/ssl/certs"
+ else
+ myconf+="--without-ssl"
+ fi
+ econf \
+ $(use_with ldap) \
+ $(use_with passfile passfile .pinepwd) \
+ $(use_with kerberos krb5) \
+ $(use_with threads pthread) \
+ $(use_with spell interactive-spellcheck /usr/bin/aspell) \
+ $(use_enable nls) \
+ $(use_with ipv6) \
+ $(use_with smime) \
+ ${myconf}
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/alpine.1
+ else
+ emake DESTDIR="${D}" install
+ doman doc/rpdump.1 doc/rpload.1
+ fi
+
+ dodoc NOTICE README*
+
+ if use doc ; then
+ dodoc doc/brochure.txt doc/tech-notes.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+ fi
+}