summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-09-09 18:37:19 +0200
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-09-10 15:32:11 +0100
commit7113e237014052a0a7b2e27adf969ce1f10978fc (patch)
tree62de48aad796a24f3519665092e298d97a25b46c /mail-filter/afew/afew-1.2.0.ebuild
parentdev-python/future: keyworded 0.16.0 for ppc64, bug #592910 (diff)
downloadgentoo-7113e237014052a0a7b2e27adf969ce1f10978fc.tar.gz
gentoo-7113e237014052a0a7b2e27adf969ce1f10978fc.tar.bz2
gentoo-7113e237014052a0a7b2e27adf969ce1f10978fc.zip
mail-filter/afew: Add version bump 1.2.0
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=630494
Diffstat (limited to 'mail-filter/afew/afew-1.2.0.ebuild')
-rw-r--r--mail-filter/afew/afew-1.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/mail-filter/afew/afew-1.2.0.ebuild b/mail-filter/afew/afew-1.2.0.ebuild
new file mode 100644
index 000000000000..056d2071a9bc
--- /dev/null
+++ b/mail-filter/afew/afew-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Initial tagging script for Notmuch"
+HOMEPAGE="https://github.com/afewmail/afew"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ net-mail/notmuch[python,${PYTHON_USEDEP}]"
+
+DOCS=( "README.rst" )
+
+src_prepare() {
+ sed -r \
+ -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
+ -e "/^([[:space:]]+)setup_requires=.*,$/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc afew/defaults/afew.config
+}