summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:39:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:30 +0100
commit72ef66d02d26ff4e14f0a46773b0d63f638b890f (patch)
tree4fd696255e51d94cd70a819d6b4c8ebacdc6716f /mail-filter/afew/afew-1.3.0-r1.ebuild
parentgames-board/pysolfc: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-72ef66d02d26ff4e14f0a46773b0d63f638b890f.tar.gz
gentoo-72ef66d02d26ff4e14f0a46773b0d63f638b890f.tar.bz2
gentoo-72ef66d02d26ff4e14f0a46773b0d63f638b890f.zip
mail-filter/afew: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-filter/afew/afew-1.3.0-r1.ebuild')
-rw-r--r--mail-filter/afew/afew-1.3.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail-filter/afew/afew-1.3.0-r1.ebuild b/mail-filter/afew/afew-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3f9be50612f1
--- /dev/null
+++ b/mail-filter/afew/afew-1.3.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Initial tagging script for Notmuch"
+HOMEPAGE="https://github.com/afewmail/afew"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/dkimpy[${PYTHON_MULTI_USEDEP}]
+ net-mail/notmuch[python,${PYTHON_MULTI_USEDEP}]
+ ')"
+
+DOCS=( "README.rst" )
+
+src_prepare() {
+ sed -r \
+ -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
+ -e "/^([[:space:]]+)setup_requires=.*,$/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc afew/defaults/afew.config
+}