summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/bmf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/bmf')
-rw-r--r--mail-filter/bmf/Manifest1
-rw-r--r--mail-filter/bmf/bmf-0.9.4-r2.ebuild56
-rw-r--r--mail-filter/bmf/files/bmf-0.9.4_QA.patch19
-rw-r--r--mail-filter/bmf/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/mail-filter/bmf/Manifest b/mail-filter/bmf/Manifest
new file mode 100644
index 000000000000..65d4167ae72e
--- /dev/null
+++ b/mail-filter/bmf/Manifest
@@ -0,0 +1 @@
+DIST bmf-0.9.4.tar.gz 36740 SHA256 7eed21802f95df2321ac4c958f99e14d2809852a5708700b633e1abb032c9ce1
diff --git a/mail-filter/bmf/bmf-0.9.4-r2.ebuild b/mail-filter/bmf/bmf-0.9.4-r2.ebuild
new file mode 100644
index 000000000000..a744a1115a49
--- /dev/null
+++ b/mail-filter/bmf/bmf-0.9.4-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs eutils
+
+IUSE="mysql berkdb"
+
+DESCRIPTION="A fast and small Bayesian spam filter"
+HOMEPAGE="http://bmf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bmf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="mysql? ( virtual/mysql )
+ berkdb? ( >=sys-libs/db-3.2.9 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # respect CFLAGS
+ sed -i -e '/D_LINUX/s/CFLAGS="$CCDBG/CFLAGS+=" $CCDBG/' \
+ "${S}/configure" || die
+
+ # include mysql headers
+ sed -i -e '/HAVE_MYSQL/s/HAVE_MYSQL/HAVE_MYSQL `mysql_config --include`/' \
+ "${S}/configure" || die
+
+ epatch "${FILESDIR}/${P}_QA.patch"
+}
+
+src_configure() {
+ # this is not an autotools script
+ ./configure \
+ $(use_with mysql) \
+ $(use_with berkdb libdb) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README AUTHORS ChangeLog
+}
+
+pkg_postinst() {
+ elog
+ elog "Important: Remember to train bmf before you start using it."
+ elog "See the README file for further instructions on training and using bmf"
+ elog "with procmail."
+ elog
+}
diff --git a/mail-filter/bmf/files/bmf-0.9.4_QA.patch b/mail-filter/bmf/files/bmf-0.9.4_QA.patch
new file mode 100644
index 000000000000..f911e05d58f9
--- /dev/null
+++ b/mail-filter/bmf/files/bmf-0.9.4_QA.patch
@@ -0,0 +1,19 @@
+--- dbh.c 2002-10-14 07:09:51.000000000 +0000
++++ dbh.c 2012-02-24 10:52:07.000000000 +0000
+@@ -60,12 +60,16 @@
+ case db_text:
+ pdb = (dbh_t*)dbtext_db_open( dbhost, dbname, dbuser, dbpass );
+ break;
++#ifdef HAVE_LIBDB
+ case db_db:
+ pdb = (dbh_t*)dbdb_db_open( dbhost, dbname, dbuser, dbpass );
+ break;
++#endif
++#ifdef HAVE_MYSQL
+ case db_mysql:
+ pdb = (dbh_t*) dbmysql_db_open( dbhost, dbname, dbuser, dbpass );
+ break;
++#endif
+ default:
+ assert(false);
+ }
diff --git a/mail-filter/bmf/metadata.xml b/mail-filter/bmf/metadata.xml
new file mode 100644
index 000000000000..85b79b68dd90
--- /dev/null
+++ b/mail-filter/bmf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">bmf</remote-id>
+ </upstream>
+</pkgmetadata>