summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-12 13:04:00 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-12 13:04:00 +0100
commitd728a1ab21ddd83087e7c4327ceafa5378ff6846 (patch)
tree95a3c75f4b7b97236f10e39d72833e9bea08a249 /mail-filter/dcc
parentmail-filter/dcc: Port to EAPI 7 (diff)
downloadgentoo-d728a1ab21ddd83087e7c4327ceafa5378ff6846.tar.gz
gentoo-d728a1ab21ddd83087e7c4327ceafa5378ff6846.tar.bz2
gentoo-d728a1ab21ddd83087e7c4327ceafa5378ff6846.zip
mail-filter/dcc: Remove old
Closes: https://github.com/gentoo/gentoo/pull/18945 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'mail-filter/dcc')
-rw-r--r--mail-filter/dcc/Manifest1
-rw-r--r--mail-filter/dcc/dcc-1.3.154.ebuild132
-rw-r--r--mail-filter/dcc/dcc-1.3.158-r1.ebuild2
3 files changed, 1 insertions, 134 deletions
diff --git a/mail-filter/dcc/Manifest b/mail-filter/dcc/Manifest
index 6560842e319e..7eb162306044 100644
--- a/mail-filter/dcc/Manifest
+++ b/mail-filter/dcc/Manifest
@@ -1,2 +1 @@
-DIST dcc-1.3.154.tar.Z 1711292 BLAKE2B 3e53488e718b13a1c36c1531f552ee811f42b274f4c24f26b484bd2b184fa3c34e0241be82aad1f6fa1a7a485fc172efdfea1dd7938fe190d9bbffa711f20abf SHA512 703bd3de44ccff3f318239dc2ca26a285f83ae0340a91391bcc5b719c298e77c8122d1502665350ddfc9fb14f12d9b6a56cba422ff8985db9cee6c91091fb987
DIST dcc-1.3.158.tar.Z 1714175 BLAKE2B 19e11e9e78268e76bf97f16ad6f03f0bb114ec9fbc9b1f8bb6ca7ce72fa419b1e50a6d35ee32ed5352b13da96002d313c00a07395317d33082eb69c9ae60008e SHA512 24fba5ea713e8df1468644508c323d64b3868685716b7cc02263933476940a807cfc4593432a9195371308c83d4ea93653e89634681d95dcb32f5d65c7274599
diff --git a/mail-filter/dcc/dcc-1.3.154.ebuild b/mail-filter/dcc/dcc-1.3.154.ebuild
deleted file mode 100644
index b4bdaf7abd15..000000000000
--- a/mail-filter/dcc/dcc-1.3.154.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit base eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Distributed Checksum Clearinghouse"
-HOMEPAGE="http://www.rhyolite.com/anti-spam/dcc/"
-SRC_URI="http://www.rhyolite.com/anti-spam/dcc/source/old/${P}.tar.Z"
-
-LICENSE="DCC GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" #
-IUSE="cgi ipv6 rrdtool milter"
-
-RDEPEND="dev-lang/perl
- rrdtool? ( net-analyzer/rrdtool )
- || ( net-misc/wget www-client/fetch net-misc/curl net-ftp/ftp )
- milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )"
-DEPEND="sys-apps/sed
- sys-devel/gcc
- ${RDEPEND}"
-
-dcc_cgibin=/var/www/localhost/cgi-bin/dcc
-dcc_homedir=/var/dcc
-dcc_libexec=/usr/sbin
-dcc_man=/usr/share/man
-dcc_rundir=/var/run/dcc
-
-PATCHES=( "${FILESDIR}"/dcc-1.3.140-freebsd.patch )
-
-src_configure() {
- tc-export CC AR RANLIB
- local myconf
- myconf="${myconf} --homedir=${dcc_homedir}"
- myconf="${myconf} --bindir=/usr/bin"
- myconf="${myconf} --libexecdir=${dcc_libexec}"
- myconf="${myconf} --mandir=/usr/share/man"
- myconf="${myconf} --with-updatedcc_pfile=${dcc_homedir}/updatecc.pfile"
- myconf="${myconf} --with-installroot=${D}"
- # sigh. should be DCC-MD5 but see line 486 in the shipped configure script
- myconf="${myconf} --with-DDC-MD5"
- myconf="${myconf} --with-uid=root"
- myconf="${myconf} --enable-server"
- myconf="${myconf} --enable-dccifd"
- myconf="${myconf} --with-rundir=${dcc_rundir}"
- myconf="${myconf} --with-db-memory=64"
- myconf="${myconf} --with-max-db-mem=128"
- myconf="${myconf} --with-max-log-size=0"
- myconf="${myconf} --with-make-cmd=${MAKE:-make}"
- myconf="${myconf} $(use_enable ipv6 IPv6)"
- myconf="${myconf} $(use_with cgi cgibin ${dcc_cgibin})"
- myconf="${myconf} $(use_enable milter dccm)"
- use milter && myconf="${myconf} --with-sendmail="
-
- einfo "Using config: ${myconf}"
-
- # This is NOT a normal configure script.
- ./configure ${myconf} || die "configure failed!"
-}
-
-moveconf() {
- local into=/etc/dcc/
- for i in $@; do
- mv "${D}${dcc_homedir}/${i}" "${D}${into}"
- dosym "${into}${i}" "${dcc_homedir}/${i}"
- done
-}
-
-src_install() {
- # stolen from the RPM .spec and modified for gentoo
- MANOWN=root MANGRP=$(id -g -n root) export MANOWN MANGRP
- BINOWN="${MANOWN}" BINGRP="${MANGRP}" export BINOWN BINGRP
- DCC_PROTO_HOMEDIR="${D}${dcc_homedir}" export DCC_PROTO_HOMEDIR
- DCC_CGIBINDIR="${D}${dcc_cgibin}" export DCC_CGIBINDIR
- DCC_SUID="${BINOWN}" DCC_OWN="${BINOWN}" DCC_GRP="${BINGRP}" export DCC_SUID DCC_OWN DCC_GRP
-
- dodir /etc/cron.daily "${dcc_homedir}" /usr/bin /usr/sbin /usr/share/man/man{0,8} /etc/dcc
- if use cgi ; then
- dodir "${dcc_cgibin}"
- fi
- keepdir /var/log/dcc
-
- # This package now takes "${D}" at compile-time!
- # make DESTDIR="${D}" DCC_BINDIR="${D}"/usr/bin MANDIR="${D}"/usr/share/man/man DCC_HOMEDIR="${D}"${dcc_homedir} install || die
- emake install
-
- # branding and setting reasonable defaults
- sed -e "s/BRAND=\$/BRAND='Gentoo ${PF}'/;" \
- -e "s/GREY_ENABLE=\$/GREY_ENABLE=off/;" \
- -e "s/DCCM_LOG_AT=5\$/DCCM_LOG_AT=50/;" \
- -e "s,DCCM_LOGDIR=\"log\"\$,DCCM_LOGDIR=\"/var/log/dcc\",;" \
- -e "s/DCCM_ARGS=\$/DCCM_ARGS='-SHELO -Smail_host -SSender -SList-ID'/;" \
- -e "s/DCCIFD_ARGS=\$/DCCIFD_ARGS=\"\$DCCM_ARGS\"/;" \
- -e 's/DCCIFD_ENABLE=off/DCCIFD_ENABLE=on/' \
- -e 's/DBCLEAN_LOGDAYS=14/DBCLEAN_LOGDAYS=1/' \
- -i "${D}${dcc_homedir}/dcc_conf"
-
- if use milter ; then
- # enable milter
- sed -i -e "s:^[\t #]*\(DCCM_ENABLE[\t ]*=[\t ]*\).*:\1on:g" \
- "${D}${dcc_homedir}"/dcc_conf
- fi
-
- # provide cronjob
- mv "${D}"/usr/sbin/cron-dccd "${D}"/etc/cron.daily/dccd || die "mv failed"
-
- # clean up
- mv "${D}"/usr/sbin/logger "${D}"/usr/sbin/logger-dcc || die "mv failed"
-
- statslist="${D}/usr/sbin/{dcc-stats-graph,dcc-stats-init,dcc-stats-collect}"
- if ! use rrdtool; then
- # remove rrdtool interface scripts
- eval rm -f ${statslist} || die "Failed to clean up rrdtool scripts"
- fi
-
- # clean up
- rm -f "${D}"/usr/sbin/{rcDCC,updatedcc}
-
- # place configuration files into /etc instead of /var/dcc
- moveconf dcc_conf flod grey_flod grey_whitelist ids map map.txt whiteclnt whitecommon whitelist
-
- newinitd "${FILESDIR}"/dcc.initd-1.3.154 dcc
- newconfd "${FILESDIR}"/dcc.confd dcc
-
- rmdir "${D}"/var/dcc/log/
-
- dodoc CHANGES RESTRICTIONS
- dohtml *.html
- doman *.{0,8}
-}
diff --git a/mail-filter/dcc/dcc-1.3.158-r1.ebuild b/mail-filter/dcc/dcc-1.3.158-r1.ebuild
index be9cf2452f69..4f94c517ed2f 100644
--- a/mail-filter/dcc/dcc-1.3.158-r1.ebuild
+++ b/mail-filter/dcc/dcc-1.3.158-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.rhyolite.com/dcc/source/old/${P}.tar.Z"
LICENSE="DCC GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" #
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="cgi ipv6 rrdtool milter"
RDEPEND="