summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-12-22 12:29:04 +0100
committerFabian Groffen <grobian@gentoo.org>2017-12-22 12:29:13 +0100
commitb2eab8cee39c59cc922c73f830ccfbc021d8e562 (patch)
tree271fe39eb6dfd3c19fb43c8f96910d6c9cb98a4a /mail-filter/opendmarc
parentmedia-video/smplayer: remove old (diff)
downloadgentoo-b2eab8cee39c59cc922c73f830ccfbc021d8e562.tar.gz
gentoo-b2eab8cee39c59cc922c73f830ccfbc021d8e562.tar.bz2
gentoo-b2eab8cee39c59cc922c73f830ccfbc021d8e562.zip
mail-filter/opendmarc: add systemd service file by Garry Filakhtov
Closes: https://bugs.gentoo.org/622606 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'mail-filter/opendmarc')
-rw-r--r--mail-filter/opendmarc/files/opendmarc.service20
-rw-r--r--mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild3
2 files changed, 22 insertions, 1 deletions
diff --git a/mail-filter/opendmarc/files/opendmarc.service b/mail-filter/opendmarc/files/opendmarc.service
new file mode 100644
index 000000000000..e450637a02f6
--- /dev/null
+++ b/mail-filter/opendmarc/files/opendmarc.service
@@ -0,0 +1,20 @@
+[Unit]
+Description=Domain-based Message Authentication, Reporting and Conformance (DMARC) Milter
+Documentation=man:opendmarc(8) man:opendmarc.conf(5) man:opendmarc-expire(8) man:opendmarc-importstats(8) man:opendmarc-reports(8)
+man:opendmarc-check(8) man:opendmarc-import(8) man:opendmarc-params(8) http://www.trusteddomain.org/opendmarc/
+After=network.target nss-lookup.target syslog.target
+
+[Service]
+User=milter
+Group=milter
+PIDFile=/var/run/opendmarc/opendmarc.pid
+ExecStartPre=/usr/sbin/opendmarc -c /etc/opendmarc/opendmarc.conf -n
+ExecStart=/usr/sbin/opendmarc -c /etc/opendmarc/opendmarc.conf -f -P /var/run/opendmarc/opendmarc.pid
+ExecReload=/bin/kill -USR1 $MAINPID
+RuntimeDirectory=opendmarc
+RuntimeDirectoryMode=0750
+Restart=on-failure
+RestartSec=3
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file
diff --git a/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild b/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
index f701f5636acd..1185e2523296 100644
--- a/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
+++ b/mail-filter/opendmarc/opendmarc-1.3.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit user
+inherit user systemd
DESCRIPTION="Open source DMARC implementation "
HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
@@ -50,6 +50,7 @@ src_install() {
newinitd "${FILESDIR}"/opendmarc.initd opendmarc
newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+ systemd_dounit "${FILESDIR}/${PN}.service"
dodir /etc/opendmarc