summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-11-19 21:50:20 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-11-19 21:56:43 +0100
commit5ed1b43da87f58c3c69319d81a81ff71438725ce (patch)
tree7912e3c009c7ed910547dd9b7bc822c35c948143 /mail-filter/postsrsd
parentnet-analyzer/nagios-check_logfiles: version bump (diff)
downloadgentoo-5ed1b43da87f58c3c69319d81a81ff71438725ce.tar.gz
gentoo-5ed1b43da87f58c3c69319d81a81ff71438725ce.tar.bz2
gentoo-5ed1b43da87f58c3c69319d81a81ff71438725ce.zip
mail-filter/postsrsd: stop ignoring config file options (fixes bug 600152)
Package-Manager: portage-2.3.0
Diffstat (limited to 'mail-filter/postsrsd')
-rw-r--r--mail-filter/postsrsd/files/postsrsd.init-r130
-rw-r--r--mail-filter/postsrsd/postsrsd-1.4-r1.ebuild25
2 files changed, 55 insertions, 0 deletions
diff --git a/mail-filter/postsrsd/files/postsrsd.init-r1 b/mail-filter/postsrsd/files/postsrsd.init-r1
new file mode 100644
index 000000000000..023a96897085
--- /dev/null
+++ b/mail-filter/postsrsd/files/postsrsd.init-r1
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 2015-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+PIDFILE=/var/run/$SVCNAME.pid
+SRS_DOMAIN="${SRS_DOMAIN:-`postconf -h mydomain || true`}"
+SRS_EXCLUDE_DOMAINS="${SRS_EXCLUDE_DOMAINS:-''}"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --name $SVCNAME \
+ --exec /usr/sbin/postsrsd \
+ -- -f "$SRS_FORWARD_PORT" -r "$SRS_REVERSE_PORT" \
+ -d "$SRS_DOMAIN" -s "$SRS_SECRET" -a "$SRS_SEPARATOR" \
+ -u "$RUN_AS" -p "$PIDFILE" -c "$CHROOT" \
+ -D -X"$SRS_EXCLUDE_DOMAINS"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --name $SVCNAME
+ eend $?
+}
diff --git a/mail-filter/postsrsd/postsrsd-1.4-r1.ebuild b/mail-filter/postsrsd/postsrsd-1.4-r1.ebuild
new file mode 100644
index 000000000000..763685e041cc
--- /dev/null
+++ b/mail-filter/postsrsd/postsrsd-1.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils user
+
+DESCRIPTION="Postfix Sender Rewriting Scheme daemon"
+SRC_URI="https://github.com/roehling/postsrsd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/roehling/postsrsd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}/postsrsd-r1.init" postsrsd
+ newconfd "${BUILD_DIR}/postsrsd.default" postsrsd
+}