summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-14 23:47:35 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-15 00:04:12 -0500
commit42dbd2ba87c152d32d61df0a0e69b62f1f453ae4 (patch)
tree52708a0e3802a3818f0e48600387c10327975196 /mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild
parentsys-auth/munge: fix lpe, bug 602596 (diff)
downloadgentoo-42dbd2ba87c152d32d61df0a0e69b62f1f453ae4.tar.gz
gentoo-42dbd2ba87c152d32d61df0a0e69b62f1f453ae4.tar.bz2
gentoo-42dbd2ba87c152d32d61df0a0e69b62f1f453ae4.zip
mail-filter/pypolicyd-spf: replace v2.0.0 with v2.0.1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild')
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild
new file mode 100644
index 000000000000..fb74bcf8d7ed
--- /dev/null
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6"
+
+inherit distutils-r1
+
+DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/${PN}"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pyspf-2.0.9[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+
+ sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}