summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-10 21:00:20 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-10 21:00:20 -0400
commitd5e3ea5ff60d15b1d87704cc0268f6a6438ac42b (patch)
tree1b0677af536710fcc7342531cdc997fb11a3bc77 /mail-filter/spamdyke/spamdyke-4.3.0.ebuild
parentmail-filter/spamdyke: add libressl support (diff)
downloadgentoo-d5e3ea5ff60d15b1d87704cc0268f6a6438ac42b.tar.gz
gentoo-d5e3ea5ff60d15b1d87704cc0268f6a6438ac42b.tar.bz2
gentoo-d5e3ea5ff60d15b1d87704cc0268f6a6438ac42b.zip
mail-filter/spamdyke: rename USE=tls to ssl for consistency.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'mail-filter/spamdyke/spamdyke-4.3.0.ebuild')
-rw-r--r--mail-filter/spamdyke/spamdyke-4.3.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail-filter/spamdyke/spamdyke-4.3.0.ebuild b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
index e3491cace8b0..18dbbc7848c4 100644
--- a/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
+++ b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI="5"
+
inherit eutils autotools
DESCRIPTION="A drop-in connection-time spam filter for qmail"
@@ -12,9 +13,9 @@ SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+tls"
+IUSE="+ssl"
-DEPEND="tls? ( dev-libs/openssl )"
+DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
virtual/qmail"
@@ -23,7 +24,7 @@ S=${WORKDIR}/${P}/${PN}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc46.patch
echo "# Configuration option for ${PN}" > ${PN}.conf
- if use tls; then
+ if use ssl; then
echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
>> ${PN}.conf
fi
@@ -41,7 +42,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable tls) || die "econf failed"
+ $(use_enable ssl tls) || die "econf failed"
cd ../utils
econf || die "econf failed in utils"
}