summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 02:01:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 02:01:47 +0100
commit0ec84e9a00b10cdae9ec774dc0fed3ceee3b84e8 (patch)
tree2f7180e9c93088d2dc5720bcbe5490a9474252b8 /mail-filter
parentgnome-extra/chrome-gnome-shell: Remove old (py3.6) (diff)
downloadgentoo-0ec84e9a00b10cdae9ec774dc0fed3ceee3b84e8.tar.gz
gentoo-0ec84e9a00b10cdae9ec774dc0fed3ceee3b84e8.tar.bz2
gentoo-0ec84e9a00b10cdae9ec774dc0fed3ceee3b84e8.zip
mail-filter/pyzor: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/pyzor/Manifest1
-rw-r--r--mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch85
-rw-r--r--mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch41
-rw-r--r--mail-filter/pyzor/pyzor-1.0.0-r1.ebuild71
4 files changed, 0 insertions, 198 deletions
diff --git a/mail-filter/pyzor/Manifest b/mail-filter/pyzor/Manifest
index 418fdd57e1cd..23730c858e15 100644
--- a/mail-filter/pyzor/Manifest
+++ b/mail-filter/pyzor/Manifest
@@ -1,2 +1 @@
-DIST pyzor-1.0.0.tar.gz 126276 BLAKE2B c60f26c53bf118c88dacbc49ddd414473748af1868b383a9c937ecf3cfe426ecdd60f64388fe7e555bd4641ef445769600e40879279dd544ef9ea32bd0dab6b9 SHA512 b3fb8b2c5261e187a2ab3a5a3b12d221df7de08766c6bb2ad9990c0f23517534871ecc9d5ad529e79b0d0aef8b2b800728320c57435a8c0d8c3f80a4ba0f7e4a
DIST pyzor-1.0.0_p20200523.tar.gz 138077 BLAKE2B 13ad30f06ce32a24a42dd5aaa21ad2a6700df1bac3dc54a86532748688b094ee0f56a8e28e34336298388c6e0b95868e95d040866c9afa561d867069496608fe SHA512 afe3b14794aea68b1a7d72840257976c7c9f755a6f6dcaaf6ebacab465c176fe2aa84f3fe176006cdbe26ef0b07ed949f75f6ef729f65c604fadf6ce8472da8f
diff --git a/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch b/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch
deleted file mode 100644
index 03031a976690..000000000000
--- a/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 66225b32d2774cf37fa7f702f7eb26cd94094482 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Sun, 4 Mar 2018 17:27:01 -0500
-Subject: [PATCH 1/1] scripts/pyzor: replace the client with the git (+ issue
- 64 fix) version.
-
----
- scripts/pyzor | 33 +++++++++++++++++++++++++++------
- 1 file changed, 27 insertions(+), 6 deletions(-)
-
-diff --git a/scripts/pyzor b/scripts/pyzor
-index 19b1d21..86c6f7d 100755
---- a/scripts/pyzor
-+++ b/scripts/pyzor
-@@ -17,9 +17,9 @@ import tempfile
- import threading
-
- try:
-- import ConfigParser
--except ImportError:
- import configparser as ConfigParser
-+except ImportError:
-+ import ConfigParser
-
- import pyzor.digest
- import pyzor.client
-@@ -110,7 +110,7 @@ def load_configuration():
- config = ConfigParser.ConfigParser()
- # Set the defaults.
- config.add_section("client")
-- for key, value in defaults.iteritems():
-+ for key, value in defaults.items():
- config.set("client", key, value)
- # Override with the configuration.
- config.read(os.path.join(options.homedir, "config"))
-@@ -171,14 +171,35 @@ def _get_input_digests(dummy):
-
-
- def _get_input_msg(digester):
-- msg = email.message_from_file(sys.stdin)
-+ msg = email.message_from_bytes(get_binary_stdin().read())
- digested = digester(msg).value
- yield digested
-
-
-+def _is_binary_reader(stream, default=False):
-+ try:
-+ return isinstance(stream.read(0), bytes)
-+ except Exception:
-+ return default
-+
-+
-+def get_binary_stdin():
-+ # sys.stdin might or might not be binary in some extra cases. By
-+ # default it's obviously non binary which is the core of the
-+ # problem but the docs recommend changing it to binary for such
-+ # cases so we need to deal with it.
-+ is_binary = _is_binary_reader(sys.stdin, False)
-+ if is_binary:
-+ return sys.stdin
-+ buf = getattr(sys.stdin, 'buffer', None)
-+ if buf is not None and _is_binary_reader(buf, True):
-+ return buf
-+ raise RuntimeError('Did not manage to get binary stdin')
-+
-+
- def _get_input_mbox(digester):
- tfile = tempfile.NamedTemporaryFile()
-- tfile.write(sys.stdin.read().encode("utf8"))
-+ tfile.write(get_binary_stdin().read())
- tfile.seek(0)
- mbox = mailbox.mbox(tfile.name)
- for msg in mbox:
-@@ -372,7 +393,7 @@ def genkey(client, servers, config, hash_func=hashlib.sha1):
- return False
- # pylint: disable-msg=W0612
- salt = "".join([chr(random.randint(0, 255))
-- for unused in xrange(hash_func(b"").digest_size)])
-+ for unused in range(hash_func(b"").digest_size)])
- if sys.version_info >= (3, 0):
- salt = salt.encode("utf8")
- salt_digest = hash_func(salt)
---
-2.13.6
-
diff --git a/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch b/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch
deleted file mode 100644
index 93d0f07a2579..000000000000
--- a/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From e4f06e21f697b863fa45a50e535ff0c6e3621a60 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Sun, 25 Mar 2018 10:14:21 -0400
-Subject: [PATCH 1/1] scripts/pyzor: undo ConfigParser python-3.x
- compatibility.
-
-The build system for pyzor-1.0.0 still runs the 2to3 utility on the
-scripts to be installed. As an unintended side-effect, the python-3.x
-"try... import... except" compatibility block for the ConfigParser <->
-configparser module gets modified (the module name gets mistakenly
-lowercased).
-
-This commit puts back the python-2.x "import ConfigParser" line
-unconditionally, and we'll have to rely on 2to3 to fix it when run
-under python-3.x. In newer versions of pyzor, the automatic 2to3 will
-not happen.
-
-Bug: https://bugs.gentoo.org/643692
----
- scripts/pyzor | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/scripts/pyzor b/scripts/pyzor
-index 86c6f7d..2750d92 100755
---- a/scripts/pyzor
-+++ b/scripts/pyzor
-@@ -16,10 +16,7 @@ import optparse
- import tempfile
- import threading
-
--try:
-- import configparser as ConfigParser
--except ImportError:
-- import ConfigParser
-+import ConfigParser
-
- import pyzor.digest
- import pyzor.client
---
-2.16.1
-
diff --git a/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild b/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild
deleted file mode 100644
index af40ded0281c..000000000000
--- a/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-MY_PV="1-0-0"
-DESCRIPTION="A distributed, collaborative spam detection and filtering network"
-HOMEPAGE="https://github.com/SpamExperts/pyzor"
-SRC_URI="https://github.com/SpamExperts/pyzor/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc gdbm gevent pyzord redis test"
-# The test suite is py2-only
-RESTRICT="test"
-
-# The mysql-python library is always required for the MySQL engine. We
-# depend on it conditionally here because otherwise repoman will balk at
-# the potential conflict between PYTHON_TARGETS and USE=mysql. But as a
-# result, if you try to use the MySQL engine with python-3.x, it just
-# won't work because you'll be missing the library.
-RDEPEND="
- pyzord? (
- gdbm? ( $(python_gen_impl_dep 'gdbm') )
- redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
- gevent? ( dev-python/gevent[${PYTHON_USEDEP}] )
- )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-# TODO: maybe upstream would support skipping tests for which the
-# dependencies are missing?
-REQUIRED_USE="pyzord? ( || ( gdbm redis ) )
- test? ( gdbm redis )"
-S="${WORKDIR}/${PN}-release-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}/read-stdin-as-binary-in-get_input_msg.patch"
- "${FILESDIR}/unfix-configparser-compat-for-2to3.patch"
-)
-
-python_test() {
- PYTHONPATH=. "${PYTHON}" ./tests/unit/__init__.py
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}
-
-src_install() {
- distutils-r1_src_install
-
- if use pyzord; then
- dodir /usr/sbin
- mv "${D}"usr/bin/pyzord* "${ED}usr/sbin" \
- || die "failed to relocate pyzord"
- else
- rm "${D}"usr/bin/pyzord* || die "failed to remove pyzord"
- fi
-}