summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-10-26 09:21:20 +0200
committerFabian Groffen <grobian@gentoo.org>2021-10-26 09:23:15 +0200
commit1e5229b1170c8b1b151e70167a4b600c4a545fbc (patch)
tree1f0be6e60926fbf62e80327c4f906def34c48032 /mail-filter
parentmedia-sound/drumstick: bump to 2.4.1 (diff)
downloadgentoo-1e5229b1170c8b1b151e70167a4b600c4a545fbc.tar.gz
gentoo-1e5229b1170c8b1b151e70167a4b600c4a545fbc.tar.bz2
gentoo-1e5229b1170c8b1b151e70167a4b600c4a545fbc.zip
mail-filter/libspf2-1.2.11: add musl and glibc patches
Closes: https://bugs.gentoo.org/806583 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/libspf2/files/libspf2-1.2.11-musl.patch30
-rw-r--r--mail-filter/libspf2/files/libspf2-1.2.11-undefined-dn_.patch138
-rw-r--r--mail-filter/libspf2/libspf2-1.2.11.ebuild2
3 files changed, 170 insertions, 0 deletions
diff --git a/mail-filter/libspf2/files/libspf2-1.2.11-musl.patch b/mail-filter/libspf2/files/libspf2-1.2.11-musl.patch
new file mode 100644
index 000000000000..9867dc0d1b4f
--- /dev/null
+++ b/mail-filter/libspf2/files/libspf2-1.2.11-musl.patch
@@ -0,0 +1,30 @@
+assorted fixes for musl
+
+--- a/src/include/spf_dns.h
++++ a/src/include/spf_dns.h
+@@ -99,11 +99,13 @@
+ */
+
+ #if !defined(HAVE_NETDB_H) && !defined(_WIN32)
+-#define NETDB_SUCCESS 0
+ #define HOST_NOT_FOUND 1 /**< NXDOMAIN (authoritative answer)*/
+ #define TRY_AGAIN 2 /**< SERVFAIL (no authoritative answer)*/
+ #define NO_RECOVERY 3 /**< invalid/unimplmeneted query */
+ #define NO_DATA 4 /**< host found, but no RR of req type*/
++#endif
++#ifndef NETDB_SUCCESS
++#define NETDB_SUCCESS 0
+ #endif
+ typedef int SPF_dns_stat_t;
+
+--- a/src/libspf2/spf_dns_resolv.c
++++ b/src/libspf2/spf_dns_resolv.c
+@@ -606,7 +606,7 @@ SPF_dns_resolv_free(SPF_dns_server_t *spf_dns_server)
+ {
+ SPF_ASSERT_NOTNULL(spf_dns_server);
+
+-#if ! HAVE_DECL_RES_NINIT
++#if ! HAVE_DECL_RES_NINIT && HAVE_RES_CLOSE
+ res_close();
+ #endif
+
diff --git a/mail-filter/libspf2/files/libspf2-1.2.11-undefined-dn_.patch b/mail-filter/libspf2/files/libspf2-1.2.11-undefined-dn_.patch
new file mode 100644
index 000000000000..cc2638cf7669
--- /dev/null
+++ b/mail-filter/libspf2/files/libspf2-1.2.11-undefined-dn_.patch
@@ -0,0 +1,138 @@
+From 808b584d22106828aaaa3f2a52b1d076b6e66040 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 11 Sep 2014 08:09:34 +0000
+Subject: [PATCH] provide dn_skipname
+
+---
+ configure.ac | 2 +-
+ src/libreplace/__dn_skipname.c | 87 ++++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 88 insertions(+), 1 deletion(-)
+ create mode 100644 src/libreplace/__dn_skipname.c
+
+diff --git a/configure.ac b/configure.ac
+index 63e398c..739da3b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strspn strtoul])
+ AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
+
+ AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
+-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
++AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag __dn_skipname])
+ dnl Magnus Holmgren says this avoids linking a private function
+ AC_LIBOBJ([__ns_get16])
+
+diff --git a/src/libreplace/__dn_skipname.c b/src/libreplace/__dn_skipname.c
+new file mode 100644
+index 0000000..88d48b5
+--- /dev/null
++++ b/src/libreplace/__dn_skipname.c
+@@ -0,0 +1,87 @@
++/* taken from OpenBSD source */
++/*
++ * ++Copyright++ 1985, 1993
++ * -
++ * Copyright (c) 1985, 1993
++ * The Regents of the University of California. All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. Neither the name of the University nor the names of its contributors
++ * may be used to endorse or promote products derived from this software
++ * without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ * -
++ * Portions Copyright (c) 1993 by Digital Equipment Corporation.
++ *
++ * Permission to use, copy, modify, and distribute this software for any
++ * purpose with or without fee is hereby granted, provided that the above
++ * copyright notice and this permission notice appear in all copies, and that
++ * the name of Digital Equipment Corporation not be used in advertising or
++ * publicity pertaining to distribution of the document or software without
++ * specific, written prior permission.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL
++ * WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES
++ * OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT
++ * CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
++ * DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
++ * PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
++ * ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
++ * SOFTWARE.
++ * -
++ * --Copyright--
++ */
++
++/*
++ * Skip over a compressed domain name. Return the size or -1.
++ */
++#include <sys/types.h>
++#include <resolv.h>
++
++int
++__dn_skipname(const u_char *comp_dn, const u_char *eom)
++{
++ const u_char *cp;
++ int n;
++
++ cp = comp_dn;
++ while (cp < eom && (n = *cp++)) {
++ /*
++ * check for indirection
++ */
++ switch (n & INDIR_MASK) {
++ case 0: /* normal case, n == len */
++ cp += n;
++ continue;
++ case INDIR_MASK: /* indirection */
++ cp++;
++ break;
++ default: /* illegal type */
++ return (-1);
++ }
++ break;
++ }
++ if (cp > eom)
++ return (-1);
++ return (cp - comp_dn);
++}
++
++
+--
+2.1.0
+
+keep dn_expand available, for musl and glibc-2.34
+
+diff --git a/src/libreplace/arpa_nameser.h b/src/libreplace/arpa_nameser.h
+index e59ca3d..35e32b3 100644
+--- a/src/libreplace/arpa_nameser.h
++++ b/src/libreplace/arpa_nameser.h
+@@ -59,11 +59,6 @@
+ # define __P(x) x
+ #endif
+
+-#if defined( HAVE_ARPA_NAMESER_H ) && defined( HAVE_NS_TYPE )
+-#define dn_expand __dn_expand
+-int dn_expand __P((const u_char *, const u_char *, const u_char *,
+- char *, int));
+-#endif
+ #define dn_skipname __dn_skipname
+ int dn_skipname __P((const u_char *, const u_char *));
+
diff --git a/mail-filter/libspf2/libspf2-1.2.11.ebuild b/mail-filter/libspf2/libspf2-1.2.11.ebuild
index 297928cb2fe3..e80f41ff3ea1 100644
--- a/mail-filter/libspf2/libspf2-1.2.11.ebuild
+++ b/mail-filter/libspf2/libspf2-1.2.11.ebuild
@@ -16,6 +16,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
PATCHES=(
"${FILESDIR}"/${PN}-1.2.11-memset-include-string-h.patch
+ "${FILESDIR}"/${PN}-1.2.11-undefined-dn_.patch
+ "${FILESDIR}"/${PN}-1.2.11-musl.patch
)
S=${WORKDIR}/${PN}-${GHASH}