summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-12-24 10:36:41 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-12-24 10:36:41 -0500
commit23a08d7367b3dfa0957e2ab1cfab3f799a6b3bf5 (patch)
treeaefe8dd3031766ce909df2ac2c8834d46b58aa8a /mail-filter
parentprofiles/targets/desktop/package.use: fix media-video/mpv luajit entry (diff)
downloadgentoo-23a08d7367b3dfa0957e2ab1cfab3f799a6b3bf5.tar.gz
gentoo-23a08d7367b3dfa0957e2ab1cfab3f799a6b3bf5.tar.bz2
gentoo-23a08d7367b3dfa0957e2ab1cfab3f799a6b3bf5.zip
mail-filter/opendkim: add back lua-5.2 support.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig-pt2.patch51
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r25.ebuild6
2 files changed, 53 insertions, 4 deletions
diff --git a/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig-pt2.patch b/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig-pt2.patch
new file mode 100644
index 000000000000..9e963eced4dd
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig-pt2.patch
@@ -0,0 +1,51 @@
+From 6dcab8d2e001bb4b91314693affa65e9c1a9adbd Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 22 Dec 2020 19:36:28 -0500
+Subject: [PATCH 1/2] configure.ac: drop lua5.1 pkg-config check.
+
+The official upstream name for the lua pkg-config file is "lua.pc", so
+preferring the name "lua5.1.pc" to the official one can lead to
+problems when both are installed. Specifically, if lua-5.2 is
+installed and its pkg-config file is called "lua.pc", then ./configure
+will still detect (and use!) lua-5.1 if it happens to be installed
+with just the right name.
+
+This was honestly left in only for superstitious reasons, and now it's
+actually causing problems on Gentoo systems that have more than one
+version of Lua installed. So, time to go.
+
+Closes: https://github.com/trusteddomainproject/OpenDKIM/issues/111
+---
+ configure.ac | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 828fe53f..d3d688ec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1517,20 +1517,10 @@ lua_found="no"
+
+ if test \( x"$luapath" = x"auto" -o x"$luapath" = x"yes" \) -a x"$PKG_CONFIG" != x""
+ then
+- PKG_CHECK_MODULES([LIBLUA], [lua5.1], [
++ PKG_CHECK_MODULES([LIBLUA], [lua], [
+ LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
+ lua_found="yes"
+- ],
+- [
+- AC_MSG_WARN([pkg-config for lua5.1 not found, trying lua...])
+- PKG_CHECK_MODULES([LIBLUA], [lua], [
+- LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
+- lua_found="yes"
+- ],
+- [AC_MSG_WARN([pkg-config for lua not found, trying manual search...])]
+- )
+- ]
+- )
++ ])
+ fi
+
+ if test \( x"$luapath" = x"yes" -o x"$luapath" = x"auto" \) -a x"$lua_found" = x"no"
+--
+2.26.2
+
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild
index eb05adb29aa0..b105074a89ac 100644
--- a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild
+++ b/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild
@@ -3,10 +3,7 @@
EAPI=7
-# Supports lua5-2 as well but in order for that to work the lua-pkgconfig
-# patch has to be updated not to prefer "lua5.1" over "lua" while looking
-# for Lua pkgconfig modules.
-LUA_COMPAT=( lua5-1 )
+LUA_COMPAT=( lua5-1 lua5-2 )
inherit autotools db-use eutils systemd tmpfiles lua-single
@@ -58,6 +55,7 @@ PATCHES=(
"${FILESDIR}/${P}-openrc.patch"
"${FILESDIR}/${P}-openssl-1.1.1.patch.r2"
"${FILESDIR}/${P}-lua-pkgconfig.patch"
+ "${FILESDIR}/${P}-lua-pkgconfig-pt2.patch"
"${FILESDIR}/${P}-define-P-macro-in-libvbr.patch"
"${FILESDIR}/${P}-fix-libmilter-search.patch"
)