summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-12-28 14:08:38 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-12-28 14:08:55 -0500
commit6f8585de7ea586a36cbc06530346f855540d25e0 (patch)
treef57bcb28f10850c291378e6f62581739c280bef7 /mail-filter
parentnet-misc/dropbox: drop old (diff)
downloadgentoo-6f8585de7ea586a36cbc06530346f855540d25e0.tar.gz
gentoo-6f8585de7ea586a36cbc06530346f855540d25e0.tar.bz2
gentoo-6f8585de7ea586a36cbc06530346f855540d25e0.zip
mail-filter/opendkim: new revision to disable parallel tests.
The test suite for OpenDKIM currently relies on two "setup" and "cleanup" tests being run at the beginning/end of the test suite, respectively. But when the test suite is run in parallel, that's not always guaranteed. This new revision runs the test suite sequentially to avoid the problem, which has been reported upstream. The credit for this goes to klondike, who was able to determine the root cause of the heisenbug. In the process, a minor security vulnerability (insecure /tmp path) was also reported upstream and fixed in the ebuild. Closes: https://bugs.gentoo.org/745969 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r26.ebuild (renamed from mail-filter/opendkim/opendkim-2.10.3-r25.ebuild)15
1 files changed, 15 insertions, 0 deletions
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r26.ebuild
index b105074a89ac..5aad117eed35 100644
--- a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild
+++ b/mail-filter/opendkim/opendkim-2.10.3-r26.ebuild
@@ -68,6 +68,15 @@ src_prepare() {
sed -e 's:dist_doc_DATA:dist_html_DATA:' \
-i libopendkim/docs/Makefile.am \
|| die
+
+ # The existing hard-coded path under /tmp is vulnerable to exploits
+ # since (for example) a user can create a symlink there to a file
+ # that portage will clobber. Reported upstream at,
+ #
+ # https://github.com/trusteddomainproject/OpenDKIM/issues/113
+ #
+ sed -e "s:/tmp:${T}:" -i libopendkim/tests/t-testdata.h || die
+
eautoreconf
}
@@ -121,6 +130,12 @@ src_compile() {
emake runstatedir=/run
}
+src_test() {
+ # Needed for now due to the expected sequencing of the setup/cleanup
+ # tests, https://github.com/trusteddomainproject/OpenDKIM/issues/110
+ emake -j1 check
+}
+
src_install() {
default
find "${D}" -name '*.la' -type f -delete || die