summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-30 22:02:27 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-30 22:27:31 -0500
commitc0507ac8482881f315fc92b4b6f89fc58bd4b1f9 (patch)
treeca9db6a1cea331201b453ba75ab5b4a8a4df157e /mail-filter
parenteclass/qt4-build-multilib.eclass: Remove use use sparc64-eclass (diff)
downloadgentoo-c0507ac8482881f315fc92b4b6f89fc58bd4b1f9.tar.gz
gentoo-c0507ac8482881f315fc92b4b6f89fc58bd4b1f9.tar.bz2
gentoo-c0507ac8482881f315fc92b4b6f89fc58bd4b1f9.zip
mail-filter/spamassassin: disable interactive prompts properly.
The PERL_MM_USE_DEFAULT variable is used to disable the interactive prompts in SpamAssassin's build system. However, when I dropped the perl-module.eclass a while back, I only set the variable where it seemed to be necessary. Where it is necessary turns out to depend on the package manager, because different package managers may treat the controlling terminal and file descriptors differently, and that's how MakeMaker decides whether or not to prompt you. That problem manifests in Paludis, and is hopefully fixed by exporting PERL_MM_USE_DEFAULT=1 sooner, in src_configure(). This change should only affect the build, so it is made without a new revision. Gentoo-Bug: 604518 Package-Manager: portage-2.3.0
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild b/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild
index 9ba34fc1a7ac..c2776ef83cd2 100644
--- a/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -104,6 +104,10 @@ src_prepare() {
}
src_configure() {
+ # This is how and where the perl-module eclass disables the
+ # MakeMaker interactive prompt.
+ export PERL_MM_USE_DEFAULT=1
+
# Set SYSCONFDIR explicitly so we can't get bitten by bug 48205 again
# (just to be sure, nobody knows how it could happen in the first place).
#
@@ -124,11 +128,8 @@ src_configure() {
}
src_compile() {
- PERL_MM_USE_DEFAULT=1 emake
-
- if use qmail; then
- emake spamc/qmail-spamc
- fi
+ emake
+ use qmail && emake spamc/qmail-spamc
}
src_install () {