summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2020-06-06 23:44:18 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-26 09:00:56 +0100
commit88746d67250bc81b28f59c5f6845c00364e40158 (patch)
tree842a3931337c4dd1c65f0ad0ed41e06b76eb129b /mail-mta/notqmail/notqmail-9999.ebuild
parentdev-ruby/ruby_smb: cleanup (diff)
downloadgentoo-88746d67250bc81b28f59c5f6845c00364e40158.tar.gz
gentoo-88746d67250bc81b28f59c5f6845c00364e40158.tar.bz2
gentoo-88746d67250bc81b28f59c5f6845c00364e40158.zip
mail-mta/notqmail[qmail-spp]: fix build
The original patch version does not apply to notqmail anymore, so use a rebased version instead. While at it explicitely specify some USE flag dependencies. Closes: https://bugs.gentoo.org/727322 Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Closes: https://github.com/gentoo/gentoo/pull/16826 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'mail-mta/notqmail/notqmail-9999.ebuild')
-rw-r--r--mail-mta/notqmail/notqmail-9999.ebuild35
1 files changed, 20 insertions, 15 deletions
diff --git a/mail-mta/notqmail/notqmail-9999.ebuild b/mail-mta/notqmail/notqmail-9999.ebuild
index eb09e7fa8d30..393242d48caa 100644
--- a/mail-mta/notqmail/notqmail-9999.ebuild
+++ b/mail-mta/notqmail/notqmail-9999.ebuild
@@ -36,10 +36,20 @@ SRC_URI="${SRC_URI}
highvolume? (
https://github.com/notqmail/notqmail/commit/3a22b45974ddd1230da0dfa21f886c3401bee020.patch -> ${QMAIL_BIGTODO_F}
)
- qmail-spp? ( mirror://sourceforge/qmail-spp/${QMAIL_SPP_F} )
- https://github.com/notqmail/notqmail/commit/b224a3ceb63ff8ebc57648bf304e079d0bf55023.patch -> ${PN}-1.08-auth.patch
+ qmail-spp? (
+ ssl? (
+ https://github.com/notqmail/notqmail/commit/c467ba6880aaecfe1d3f592a7738de88cb5ac79a.patch -> ${PN}-1.08-auth.patch
+ https://github.com/notqmail/notqmail/commit/d950cc34491afe90432cafcaeda61d1c1a9508e9.patch -> ${PN}-1.08-tls-spp.patch
+ )
+ !ssl? (
+ https://github.com/notqmail/notqmail/commit/b36d52a0dd7315a969f2a9a7455717466e45be23.patch -> ${PN}-1.08-spp.patch
+ )
+ )
ssl? (
- https://github.com/notqmail/notqmail/commit/ed58c2eff21612037bbcc633f4b3a8e708f522a0.patch -> ${QMAIL_TLS_F}
+ https://github.com/notqmail/notqmail/commit/0dc6a3aa9cb3440fe589ca5384ea27d683f05625.patch -> ${QMAIL_TLS_F}
+ )
+ !ssl? (
+ https://github.com/notqmail/notqmail/commit/c467ba6880aaecfe1d3f592a7738de88cb5ac79a.patch -> ${PN}-1.08-auth.patch
)
)
"
@@ -47,7 +57,7 @@ SRC_URI="${SRC_URI}
LICENSE="public-domain"
SLOT="0"
IUSE="authcram gencertdaily highvolume libressl -pop3 qmail-spp ssl test vanilla"
-REQUIRED_USE="vanilla? ( !ssl !qmail-spp !highvolume )"
+REQUIRED_USE="vanilla? ( !ssl !qmail-spp !highvolume !authcram !gencertdaily ) gencertdaily? ( ssl ) libressl? ( ssl )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -92,7 +102,6 @@ RDEPEND="${DEPEND}
src_unpack() {
genqmail_src_unpack
- use qmail-spp && qmail_spp_src_unpack
[[ ${PV} == "9999" ]] && git-r3_src_unpack
[[ ${PV} != "9999" ]] && default
@@ -104,25 +113,21 @@ PATCHES=(
src_prepare() {
if ! use vanilla; then
- if use ssl; then
+ if use qmail-spp; then
+ PATCHES+=( "${DISTDIR}/${P}-auth.patch" )
+ elif use ssl; then
PATCHES+=( "${DISTDIR}/${QMAIL_TLS_F}" )
else
PATCHES+=( "${DISTDIR}/${P}-auth.patch" )
fi
- if use highvolume; then
- PATCHES+=( "${DISTDIR}/${QMAIL_BIGTODO_F}" )
- fi
+ use highvolume && PATCHES+=( "${DISTDIR}/${QMAIL_BIGTODO_F}" )
if use qmail-spp; then
if use ssl; then
- SPP_PATCH="${QMAIL_SPP_S}/qmail-spp-smtpauth-tls-20060105.diff"
+ PATCHES+=( "${DISTDIR}/${PN}-1.08-tls-spp.patch" )
else
- SPP_PATCH="${QMAIL_SPP_S}/netqmail-spp.diff"
+ PATCHES+=( "${DISTDIR}/${PN}-1.08-spp.patch" )
fi
- # make the patch work with "-p1"
- sed -e 's#^--- \([Mq]\)#--- a/\1#' -e 's#^+++ \([Mq]\)#+++ b/\1#' -i ${SPP_PATCH} || die
-
- PATCHES+=( "${SPP_PATCH}" )
fi
fi